summaryrefslogtreecommitdiff
path: root/sci-mathematics/lean/lean-3.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-26 02:51:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-26 02:51:21 +0100
commitea6ec22f536553dcd417bc8b577418d3ebe5ce4c (patch)
tree318c03426d27d596f62898b46d48f5f6af2b070e /sci-mathematics/lean/lean-3.9999.ebuild
parent1ab3970274a99b42f555ca7959efe9ace063abd5 (diff)
gentoo auto-resync : 26:08:2022 - 02:51:21
Diffstat (limited to 'sci-mathematics/lean/lean-3.9999.ebuild')
-rw-r--r--sci-mathematics/lean/lean-3.9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-mathematics/lean/lean-3.9999.ebuild b/sci-mathematics/lean/lean-3.9999.ebuild
index 6623228581a0..307c5b95bc1b 100644
--- a/sci-mathematics/lean/lean-3.9999.ebuild
+++ b/sci-mathematics/lean/lean-3.9999.ebuild
@@ -11,14 +11,14 @@ inherit flag-o-matic cmake readme.gentoo-r1
DESCRIPTION="The Lean Theorem Prover"
HOMEPAGE="https://leanprover-community.github.io/"
-if [[ "${PV}" == *9999* ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/leanprover-community/lean.git"
else
SRC_URI="https://github.com/leanprover-community/lean/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
-S="${WORKDIR}/lean-${PV}/src"
+S="${S}/src"
LICENSE="Apache-2.0"
SLOT="0/${MAJOR}"
@@ -27,7 +27,7 @@ IUSE="debug +threads"
RDEPEND="dev-libs/gmp:="
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-CMakeLists-fix_flags.patch" )
+PATCHES=( "${FILESDIR}"/${PN}-CMakeLists-fix_flags.patch )
src_configure() {
local CMAKE_BUILD_TYPE