summaryrefslogtreecommitdiff
path: root/sci-mathematics/lean/lean-3.50.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 17:55:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 17:55:42 +0100
commitb481b54b8432c46df354eedc3532b0420a38fd5a (patch)
tree02cc62a183cabccf4aa944e0d15b047b383abf16 /sci-mathematics/lean/lean-3.50.3.ebuild
parent7288c6e5fa05acddbf692a5187d925ef85662b46 (diff)
gentoo auto-resync : 18:04:2023 - 17:55:41
Diffstat (limited to 'sci-mathematics/lean/lean-3.50.3.ebuild')
-rw-r--r--sci-mathematics/lean/lean-3.50.3.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sci-mathematics/lean/lean-3.50.3.ebuild b/sci-mathematics/lean/lean-3.50.3.ebuild
index e008b81cf582..72a23985077c 100644
--- a/sci-mathematics/lean/lean-3.50.3.ebuild
+++ b/sci-mathematics/lean/lean-3.50.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,7 +27,10 @@ IUSE="debug +threads"
RDEPEND="dev-libs/gmp:="
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${PN}-CMakeLists-fix_flags.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.50.3-gcc-13.patch
+ "${FILESDIR}"/${PN}-CMakeLists-fix_flags.patch
+)
src_configure() {
local CMAKE_BUILD_TYPE
@@ -39,7 +42,7 @@ src_configure() {
filter-lto
- local mycmakeargs=(
+ local -a mycmakeargs=(
-DALPHA=ON
-DAUTO_THREAD_FINALIZATION=ON
-DJSON=ON # bug 833900
@@ -51,7 +54,7 @@ src_configure() {
}
src_test() {
- local myctestargs=(
+ local -a myctestargs=(
# Disable problematic "style_check" cpplint test,
# this also removes the python test dependency
--exclude-regex style_check