summaryrefslogtreecommitdiff
path: root/sci-mathematics/kissat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-15 15:27:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-15 15:27:23 +0100
commit4214d835b45f0047c644e43c7fa70f1bbdb2e8b3 (patch)
tree6c4b141c9c1dbed5037a41825d113dccffa410b6 /sci-mathematics/kissat
parent4f064d2f2d61a575a6e418623bd2dc3c8599ad13 (diff)
gentoo auto-resync : 15:08:2023 - 15:27:23
Diffstat (limited to 'sci-mathematics/kissat')
-rw-r--r--sci-mathematics/kissat/Manifest2
-rw-r--r--sci-mathematics/kissat/kissat-3.1.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/kissat/Manifest b/sci-mathematics/kissat/Manifest
index ef692656c4d6..ff60f0ccc0e5 100644
--- a/sci-mathematics/kissat/Manifest
+++ b/sci-mathematics/kissat/Manifest
@@ -1,3 +1,5 @@
DIST kissat-3.0.0.tar.gz 466704 BLAKE2B 453f894884e80cfd0ee7022adbde0439d64e31a402c4bfa92f022ad41699cc5c11682d5b9069cf33f8a779afa255f103987519bc9412b49f54480bd688fbc4eb SHA512 2a5b7b9c9bb74ca8395399425519c138e135eb9adfb6e802ce8d7544c9d53e0b7687f86e6a032fcdff1c6fc01770dd7e7449e488e0ddf3e4ee1199e1448a0862
+DIST kissat-3.1.0.tar.gz 470710 BLAKE2B bd79a480209d6ff35aa431dc294018cd78ef06e5f6c431fcd23206a72183c3f18eb4a4b9b57f471f2edc7c9224a52d00ae1d75f6c9af050b1fa7e667776932a7 SHA512 226090d4e8c42197709e08341dd4623cbf7e63f2fee72e59305ab7643c3e59cfc1f9f3abb5a766e3572137b45018ed788bbdfb486e6b8d86a7317f959358f2e8
EBUILD kissat-3.0.0.ebuild 807 BLAKE2B 92016c0e2616ec1546e83e6e5d81d8c308eefd06a9dc2b3eb7e206d718fbebacdaf3efc664dbf16b6d80a2011bfa0a63284aa7fafc2a58dde2ce70f7e0bd8188 SHA512 3ded71ded97147212c4cf5b65e55e076d7adf9a7e6bcf5235afff97aea4634384baa42c5fd9054efd46c825789666b2e2a34d84f9b0d7cf3dd61d5c935b8c930
+EBUILD kissat-3.1.0.ebuild 807 BLAKE2B 92016c0e2616ec1546e83e6e5d81d8c308eefd06a9dc2b3eb7e206d718fbebacdaf3efc664dbf16b6d80a2011bfa0a63284aa7fafc2a58dde2ce70f7e0bd8188 SHA512 3ded71ded97147212c4cf5b65e55e076d7adf9a7e6bcf5235afff97aea4634384baa42c5fd9054efd46c825789666b2e2a34d84f9b0d7cf3dd61d5c935b8c930
MISC metadata.xml 762 BLAKE2B 95fefd93903442e9c5c6881127d734899535b35ffcef1e9082502774849d5b04aeb7f5f5d53b2dfc899f9b503fce0785ec5f3e8fab580965636bbb17775b10e5 SHA512 441d510f122197141ce7a4140023d858c6dbb41bd8f8ea5b8466aaa4864b51df019d0759cdf54de51eb89bf4f421fbdf8937e6349b2100cb1e92d5b8f9556c26
diff --git a/sci-mathematics/kissat/kissat-3.1.0.ebuild b/sci-mathematics/kissat/kissat-3.1.0.ebuild
new file mode 100644
index 000000000000..4c1fed10488f
--- /dev/null
+++ b/sci-mathematics/kissat/kissat-3.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Keep-it-simple and clean bare metal SAT solver written in C"
+HOMEPAGE="http://fmv.jku.at/kissat/
+ https://github.com/arminbiere/kissat/"
+SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-rel-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="!>=x11-terms/kitty-0.27"
+
+src_configure() {
+ local myopts=(
+ CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+ --kitten
+ --statistics
+ )
+ sh ./configure "${myopts[@]}" || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ dolib.a build/libkissat.a
+ exeinto /usr/bin/
+ doexe build/{kissat,kitten}
+ dodoc CONTRIBUTING NEWS.md README.md
+}