summaryrefslogtreecommitdiff
path: root/sci-mathematics/gsl-shell/gsl-shell-2.3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-24 15:48:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-24 15:48:26 +0000
commitc18398e8c10c222f0daed55f7d69339e3c7885bd (patch)
tree0e6eccd09b11586b73b18bbf3d6c606f86719d1f /sci-mathematics/gsl-shell/gsl-shell-2.3.5.ebuild
parent4003c614d3c4b320c45ab1f4b817459d4709443b (diff)
gentoo auto-resync : 24:02:2023 - 15:48:26
Diffstat (limited to 'sci-mathematics/gsl-shell/gsl-shell-2.3.5.ebuild')
-rw-r--r--sci-mathematics/gsl-shell/gsl-shell-2.3.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/gsl-shell/gsl-shell-2.3.5.ebuild b/sci-mathematics/gsl-shell/gsl-shell-2.3.5.ebuild
new file mode 100644
index 000000000000..aaa1e8873371
--- /dev/null
+++ b/sci-mathematics/gsl-shell/gsl-shell-2.3.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DOCS_BUILDER="sphinx"
+DOCS_DIR="doc/user-manual"
+DOCS_AUTODOC=0
+
+inherit meson python-any-r1 docs
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Lua interactive shell for sci-libs/gsl"
+HOMEPAGE="https://www.nongnu.org/gsl-shell/"
+SRC_URI="https://github.com/franko/gsl-shell/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=sci-libs/gsl-1.14:=
+ virtual/blas[eselect-ldso]
+ >=x11-libs/agg-2.5[X]
+ >=media-libs/freetype-2.4.10
+ sys-libs/readline:0=
+ || ( media-fonts/ubuntu-font-family media-fonts/freefont media-fonts/dejavu )
+ x11-libs/fox:1.7
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/luajit
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-fetching.patch"
+)
+
+src_compile() {
+ meson_src_compile
+ docs_compile
+}