summaryrefslogtreecommitdiff
path: root/sci-mathematics/gp2c
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sci-mathematics/gp2c
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sci-mathematics/gp2c')
-rw-r--r--sci-mathematics/gp2c/Manifest2
-rw-r--r--sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-mathematics/gp2c/Manifest b/sci-mathematics/gp2c/Manifest
index 9f11fb5eb61e..379ebed5b593 100644
--- a/sci-mathematics/gp2c/Manifest
+++ b/sci-mathematics/gp2c/Manifest
@@ -1,3 +1,5 @@
DIST gp2c-0.0.11pl2.tar.gz 851845 BLAKE2B 599469af3e9975270e6d9f88c1209ee3da9ae9ab9bfc90abf2431e00d553d427c15a509278b099a133262b6d02d6fa3f06090bd0083c46c9488e697dc5da5245 SHA512 20f7fc61480a70d3f8811d7881e0f386a1ced522b5c538443dc0a9fe3332d37a67ba68441eb512b5fefdb761e232f9316704fa456a311651161da7b4653ca4b7
+DIST gp2c-0.0.11pl3.tar.gz 854003 BLAKE2B 478307b9fa56b8e58a66001bbeac3ce6193a446cb6a339bbd65de9105924fe92a0e9c39302d836c7f3e7d2fe100ac678514d4e7eef1bdb0b880cc55763002864 SHA512 06d3680da739ce13a0a80a88c7b07a9b336acecb95f4841d8e984f1d4b66ad0a3ffe47e2abb77ad7e564fa976d16c468d62e6ddc15ede3beba00db6d92a91d97
EBUILD gp2c-0.0.11.2-r1.ebuild 742 BLAKE2B 455bef05ccc38ff584dbaef4519d0a639e5c2fbd16494ebd1dfd55e20aa0f17080f9457139f9de2626760f8ab5bfe34a248d748758749d96702ea8fa84de833e SHA512 3f45599208f38e26a70679478d17072613438502ddfd2702ee090c08d8e4272c04d50577aa5d852f8c6cb61c9709ec1c36e5ff1a996078e44f03874d28011fcb
+EBUILD gp2c-0.0.11.3.ebuild 743 BLAKE2B 317626f0ae673bf2f7bb5f5921c8a1c3c7f76b2e17b38926bf2c2b4901670bc3e74ceee1c4b35e04bb5657e04021f558126b5195ae9f2eba115843c58346c80b SHA512 17d40fccabedcbaca8e51bad72d3b39158a2587a29808088bf4721ab171739929049ac51eabf4e02fe547a7650f2da873b24dad4868f9ca7904faac643d56fb8
MISC metadata.xml 886 BLAKE2B b4dfcb3e2de5064a3a537c6598814f7ec47a7db0a9bfefcc4cba78c373ed97d0ffa08fdd2ccbf049b28900c84afe8f594d7562fe35ad7c9a0ad59f2d63d9988d SHA512 71cf581ae9463fd7f4bb8eea880a940251571b076ec008d6ae2625c8158fb2562b8f4944e7092b05ba264b0bdb31ad31d4be2392ce8c1c82ff0452b513cf8ddc
diff --git a/sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild b/sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild
new file mode 100644
index 000000000000..b7314146b675
--- /dev/null
+++ b/sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-"$(ver_rs 3 'pl')
+DESCRIPTION="A GP to C translator"
+HOMEPAGE="http://pari.math.u-bordeaux.fr/"
+SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/GP2C/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Perl is run on the build host to compile the descriptions in desc/,
+# see for example desc/Makefile.am.
+BDEPEND="dev-lang/perl"
+
+# This is the first version of pari to put pari.cfg where we expect it.
+DEPEND=">=sci-mathematics/pari-2.11.2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf --with-paricfg="${EPREFIX}/usr/share/pari/pari.cfg"
+}