summaryrefslogtreecommitdiff
path: root/sci-mathematics/gmm/gmm-5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/gmm/gmm-5.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/gmm/gmm-5.1.ebuild')
-rw-r--r--sci-mathematics/gmm/gmm-5.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-mathematics/gmm/gmm-5.1.ebuild b/sci-mathematics/gmm/gmm-5.1.ebuild
new file mode 100644
index 000000000000..afc103e6cc62
--- /dev/null
+++ b/sci-mathematics/gmm/gmm-5.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Generic C++ template library for sparse, dense and skyline matrices"
+SRC_URI="https://download.gna.org/getfem/stable/${P}.tar.gz"
+HOMEPAGE="https://www-gmm.insa-toulouse.fr/getfem/"
+
+LICENSE="|| ( LGPL-3 LGPL-3-with-linking-exception )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_configure() {
+ # required for tests, #612294
+ append-cxxflags -std=c++14
+
+ default
+}