summaryrefslogtreecommitdiff
path: root/sci-mathematics/ginac/ginac-1.8.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-13 10:28:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-13 10:28:51 +0000
commitaafdd1dcd9a66da0b1bcdfadbca62add48751897 (patch)
treed328a4fe625235ee8ea443c3b1bec1fd105af11d /sci-mathematics/ginac/ginac-1.8.7.ebuild
parente0345ef79b0b4a444151748ce1f5364fc2dd147b (diff)
gentoo auto-resync : 13:11:2023 - 10:28:51
Diffstat (limited to 'sci-mathematics/ginac/ginac-1.8.7.ebuild')
-rw-r--r--sci-mathematics/ginac/ginac-1.8.7.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/sci-mathematics/ginac/ginac-1.8.7.ebuild b/sci-mathematics/ginac/ginac-1.8.7.ebuild
deleted file mode 100644
index 49c35a7c68d2..000000000000
--- a/sci-mathematics/ginac/ginac-1.8.7.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit python-any-r1
-
-DESCRIPTION="C++ library and tools for symbolic calculations"
-SRC_URI="http://www.ginac.de/${P}.tar.bz2"
-HOMEPAGE="https://www.ginac.de/"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND=">=sci-libs/cln-1.2.2"
-DEPEND="${RDEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-texlive/texlive-fontsrecommended
- >=media-gfx/fig2dev-3.2.9-r1
- dev-texlive/texlive-latexextra
- virtual/texi2dvi
- )"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.8.2-pkgconfig.patch )
-
-src_configure() {
- econf \
- --disable-rpath \
- --disable-static
-}
-
-src_compile() {
- emake
-
- if use doc; then
- local -x VARTEXFONTS="${T}"/fonts
- emake -C doc/reference html pdf
- emake -C doc/tutorial ginac.pdf ginac.html
- fi
-}
-
-src_install() {
- default
-
- if use doc; then
- pushd doc >/dev/null || die
- newdoc tutorial/ginac.pdf tutorial.pdf
- newdoc reference/reference.pdf reference.pdf
-
- docinto html/reference
- dodoc -r reference/html_files/.
-
- docinto html
- newdoc tutorial/ginac.html tutorial.html
- popd >/dev/null || die
- fi
-
- if use examples; then
- pushd doc >/dev/null || die
- docinto examples
- dodoc examples/*.cpp examples/ginac-examples.*
- docompress -x /usr/share/doc/${PF}/examples
- popd >/dev/null || die
- fi
-
- # no static archives
- find "${ED}" -name '*.la' -delete || die
-}