summaryrefslogtreecommitdiff
path: root/sci-mathematics/ginac/ginac-1.8.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-15 12:47:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-15 12:47:43 +0000
commit6e8d3793323b8f24be801a4aaf31cdd31a8483e9 (patch)
treeeba96ef018d8dea02be411ac222fd9eb6dd4edf7 /sci-mathematics/ginac/ginac-1.8.6.ebuild
parentbc5dfb0671fb08c7da579b38b0e6abdd19da103f (diff)
gentoo auto-resync : 15:03:2024 - 12:47:43
Diffstat (limited to 'sci-mathematics/ginac/ginac-1.8.6.ebuild')
-rw-r--r--sci-mathematics/ginac/ginac-1.8.6.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/sci-mathematics/ginac/ginac-1.8.6.ebuild b/sci-mathematics/ginac/ginac-1.8.6.ebuild
deleted file mode 100644
index 1d7a466c9d4a..000000000000
--- a/sci-mathematics/ginac/ginac-1.8.6.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit python-any-r1
-
-DESCRIPTION="C++ library and tools for symbolic calculations"
-SRC_URI="http://www.ginac.de/${P}.tar.bz2"
-HOMEPAGE="https://www.ginac.de/"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND=">=sci-libs/cln-1.2.2"
-DEPEND="${RDEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
- doc? (
- app-text/doxygen
- dev-texlive/texlive-fontsrecommended
- media-gfx/transfig
- dev-texlive/texlive-latexextra
- virtual/texi2dvi
- )"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.8.2-pkgconfig.patch "${FILESDIR}"/${PN}-1.8.6-unicode.patch )
-
-src_configure() {
- econf \
- --disable-rpath \
- --disable-static
-}
-
-src_compile() {
- emake
-
- if use doc; then
- local -x VARTEXFONTS="${T}"/fonts
- emake -C doc/reference html pdf
- emake -C doc/tutorial ginac.pdf ginac.html
- fi
-}
-
-src_install() {
- default
-
- if use doc; then
- pushd doc >/dev/null || die
- newdoc tutorial/ginac.pdf tutorial.pdf
- newdoc reference/reference.pdf reference.pdf
-
- docinto html/reference
- dodoc -r reference/html_files/.
-
- docinto html
- newdoc tutorial/ginac.html tutorial.html
- popd >/dev/null || die
- fi
-
- if use examples; then
- pushd doc >/dev/null || die
- docinto examples
- dodoc examples/*.cpp examples/ginac-examples.*
- docompress -x /usr/share/doc/${PF}/examples
- popd >/dev/null || die
- fi
-
- # no static archives
- find "${ED}" -name '*.la' -delete || die
-}