summaryrefslogtreecommitdiff
path: root/sci-mathematics/gfan/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /sci-mathematics/gfan/files
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'sci-mathematics/gfan/files')
-rw-r--r--sci-mathematics/gfan/files/gfan-0.5-fix-build-system.patch55
-rw-r--r--sci-mathematics/gfan/files/gfan-0.5-fix-gcc9.patch68
2 files changed, 123 insertions, 0 deletions
diff --git a/sci-mathematics/gfan/files/gfan-0.5-fix-build-system.patch b/sci-mathematics/gfan/files/gfan-0.5-fix-build-system.patch
new file mode 100644
index 000000000000..3bf96ed088ce
--- /dev/null
+++ b/sci-mathematics/gfan/files/gfan-0.5-fix-build-system.patch
@@ -0,0 +1,55 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,5 @@
+ ALL: default
+
+-# GPROFFLAG = -pg
+- GPROFFLAG = -g
+
+ PREFIX?=/usr/local
+
+@@ -77,16 +75,13 @@
+
+ SHELL = /bin/sh
+ #ARCH = LINUX
+-CC = gcc
+ CLINKER = $(CC)
+-CXX = g++
+ CCLINKER = $(CXX)
+-#OPTFLAGS = -O2 -DGMPRATIONAL -DNDEBUG
+-OPTFLAGS = -O2 -DGMPRATIONAL -Wuninitialized
+
+-CFLAGS = $(OPTFLAGS) $(GPROFFLAG) $(ADDITIONALINCLUDEOPTIONS) #-pedantic
+-CCFLAGS = $(CFLAGS)
+-FFLAGS = $(OPTFLAGS)
++
++CFLAGS += $(GPROFFLAG) $(ADDITIONALINCLUDEOPTIONS) -Wuninitialized
++CXXFLAGS += $(GPROFFLAG) $(ADDITIONALINCLUDEOPTIONS) -Wuninitialized
++CPPFLAGS += -DGMPRATIONAL -DNDEBUG
+
+ CATSOBJECTS = $(GCATSPATH)lp_cdd.o \
+ $(SOPLEX_OBJECTS) \
+@@ -317,7 +312,7 @@
+ default: $(OBJECTS) $(ADDITIONALOBJECTS) $(EXECS)
+
+ $(MAIN): $(OBJECTS)
+- $(CCLINKER) $(OBJECTS) $(ADDITIONALLINKOPTIONS) $(GPROFFLAG) -o $(MAIN)
++ $(CCLINKER) $(LDFLAGS) $(OBJECTS) $(ADDITIONALLINKOPTIONS) $(GPROFFLAG) -o $(MAIN)
+
+ release:
+ rm -f -r $(RELEASEDIR)/*
+@@ -430,14 +425,6 @@
+ cp gfanlib.h gfanlib/
+ cp gfanlib_* gfanlib/
+ tar zcf - gfanlib > gfanlib.tar.gz
+-.c.o:
+- $(CC) $(CFLAGS) -c $<
+-.cc.o:
+- $(CXX) -c $<
+-.cpp.o:
+- $(CXX) $(CFLAGS) -c $<
+-.C.o:
+- $(CXX) -c $<
+ # wget http://ftp.sunet.se/pub/gnu/gmp/gmp-4.2.2.tar.gz
+ # tar -xzvf gmp-4.2.2.tar.gz
+ # cd gmp-4.2.2
diff --git a/sci-mathematics/gfan/files/gfan-0.5-fix-gcc9.patch b/sci-mathematics/gfan/files/gfan-0.5-fix-gcc9.patch
new file mode 100644
index 000000000000..930baf9edcf2
--- /dev/null
+++ b/sci-mathematics/gfan/files/gfan-0.5-fix-gcc9.patch
@@ -0,0 +1,68 @@
+https://bugs.gentoo.org/686484
+
+polyhedralfan.h: At global scope:
+polyhedralfan.h:77:24: error: friend declaration of ‘PolyhedralFan refinement(const PolyhedralFan&, const PolyhedralFan&, int, bool)’ specifies default arguments and isn’t a definition [-fpermissive]
+ 77 | friend PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension=-1, bool allowASingleConeOfCutOffDimension=false);
+ | ^~~~~~~~~~
+
+--- a/gfanlib_polyhedralfan.h
++++ b/gfanlib_polyhedralfan.h
+@@ -24,6 +24,8 @@
+ typedef std::map<int,IntVectorList> IncidenceList;
+
+
++class PolyhedralFan;
++PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension=-1, bool allowASingleConeOfCutOffDimension=false);
+
+ /** A PolyhedralFan is simply a collection of canonicalized PolyhedralCones.
+ * It contains no combinatorial information in the sense of a polyhedral complex.
+@@ -52,7 +54,7 @@
+ int getAmbientDimension()const;
+ int getMaxDimension()const;
+ int getMinDimension()const;
+- friend PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension=-1, bool allowASingleConeOfCutOffDimension=false);
++ friend PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension, bool allowASingleConeOfCutOffDimension);
+ ZMatrix getRays(int dim=1);//This can be called for other dimensions than 1. The term "Rays" still makes sense modulo the common linearity space
+ ZMatrix getRelativeInteriorPoints();
+ void insert(ZCone const &c);
+--- a/halfopencone.h
++++ b/halfopencone.h
+@@ -6,6 +6,9 @@
+
+ #include "polyhedralfan.h"
+
++class HalfOpenCone;
++HalfOpenCone intersection(const HalfOpenCone &a, const HalfOpenCone &b, bool findFacets=false);
++
+ class HalfOpenCone{
+ static void appendList(IntegerVectorList &to, IntegerVectorList const &from, int appendValue);
+ int liftedDimension;//ambient
+@@ -18,7 +21,7 @@
+ HalfOpenCone(int dimension_, IntegerVectorList const &equations, IntegerVectorList const &nonstrict, IntegerVectorList const &strict, bool findFacets=false, bool canonicalize=false);
+ HalfOpenCone(int ambientDimension);//full space
+ bool isEmpty();
+- friend HalfOpenCone intersection(const HalfOpenCone &a, const HalfOpenCone &b, bool findFacets=false);
++ friend HalfOpenCone intersection(const HalfOpenCone &a, const HalfOpenCone &b, bool findFacets);
+ friend bool haveEmptyIntersection(const HalfOpenCone &a, const HalfOpenCone &b);
+ PolyhedralCone closure();
+ void splitIntoRelativelyOpenCones(list<HalfOpenCone> &l);
+--- a/polyhedralfan.h
++++ b/polyhedralfan.h
+@@ -30,6 +30,8 @@
+ FPF_default=2+4+8
+ };
+
++class PolyhedralFan;
++PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension=-1, bool allowASingleConeOfCutOffDimension=false);
+
+ /** A PolyhedralFan is simply a collection of canonicalized PolyhedralCones.
+ * It contains no combinatorial information in the sense of a polyhedral complex.
+@@ -74,7 +76,7 @@
+ int getAmbientDimension()const;
+ int getMaxDimension()const;
+ int getMinDimension()const;
+- friend PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension=-1, bool allowASingleConeOfCutOffDimension=false);
++ friend PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension, bool allowASingleConeOfCutOffDimension);
+ friend PolyhedralFan product(const PolyhedralFan &a, const PolyhedralFan &b);
+ IntegerVectorList getRays(int dim=1);//This can be called for other dimensions than 1. The term "Rays" still makes sense modulo the common linearity space
+ IntegerVectorList getRelativeInteriorPoints();