summaryrefslogtreecommitdiff
path: root/sci-mathematics/gappalib-coq/gappalib-coq-1.5.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 14:04:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 14:04:41 +0000
commitb18dbdc69b2be6f0ac0db668b0bc57fb6f766afc (patch)
treee77939b82c93b9689bc1bb0bc8a55132c509cb44 /sci-mathematics/gappalib-coq/gappalib-coq-1.5.2-r1.ebuild
parent97f40b36b1afa9726e32962d11f3ac2d0bc5792e (diff)
gentoo auto-resync : 16:02:2023 - 14:04:41
Diffstat (limited to 'sci-mathematics/gappalib-coq/gappalib-coq-1.5.2-r1.ebuild')
-rw-r--r--sci-mathematics/gappalib-coq/gappalib-coq-1.5.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-mathematics/gappalib-coq/gappalib-coq-1.5.2-r1.ebuild b/sci-mathematics/gappalib-coq/gappalib-coq-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..5b11673ef1d8
--- /dev/null
+++ b/sci-mathematics/gappalib-coq/gappalib-coq-1.5.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing
+
+DESCRIPTION="Allows the certificates Gappa generates to be imported by the Coq"
+HOMEPAGE="https://gappa.gitlabpages.inria.fr/
+ https://gitlab.inria.fr/gappa/coq/"
+SRC_URI="https://gappa.gitlabpages.inria.fr/releases/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocamlopt"
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ >=sci-mathematics/coq-8.12:=
+ sci-mathematics/flocq:=
+ sci-mathematics/gappa
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/findlib"
+
+# Do not complain about CFLAGS etc since ML projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+src_compile() {
+ ./remake --jobs=$(makeopts_jobs) || die
+}
+
+src_test() {
+ ./remake --jobs=$(makeopts_jobs) check || die
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die
+
+ dodoc AUTHORS INSTALL.md NEWS.md README.md
+}