summaryrefslogtreecommitdiff
path: root/sci-mathematics/flintqs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sci-mathematics/flintqs
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sci-mathematics/flintqs')
-rw-r--r--sci-mathematics/flintqs/Manifest3
-rw-r--r--sci-mathematics/flintqs/flintqs-1.0.ebuild39
-rw-r--r--sci-mathematics/flintqs/metadata.xml24
3 files changed, 66 insertions, 0 deletions
diff --git a/sci-mathematics/flintqs/Manifest b/sci-mathematics/flintqs/Manifest
new file mode 100644
index 000000000000..bb93b4b7d83a
--- /dev/null
+++ b/sci-mathematics/flintqs/Manifest
@@ -0,0 +1,3 @@
+DIST flintqs-1.0.tar.gz 151535 BLAKE2B c05761767af65ed5e5c42e75640c0736a26de76126907a91914083791ce0fa3659fb6f9fcdddb0b7aaaf2200010d826a18e7fcbdad0ffc6f861d4bcd941caabb SHA512 8391bb13bcc91f4ea68c972f0f6eaf9aa37bedc4c8694d039a21fd5153b203d561364ae545478d34013001354c4e8a013b2e5a5cb947b6e7f453c6f0f392f8be
+EBUILD flintqs-1.0.ebuild 1009 BLAKE2B 07dca8c379b639415bd62e8cc675eb4634e2aefb62aac16314e1ae2a9e504387a42a18300994b43e2bd914d053d8d3de30cafde8bb226fdc1157df6756f90334 SHA512 254919e66b3e2ceda923e90958a478fd97ece56d3a711da7ecc1f120b8ee8ef0a033cf78b0d941566d9700debd3220ed318f3c51a592074039fdab02c4db6c1a
+MISC metadata.xml 736 BLAKE2B 553a7c524f86f30ba868d5e0db2fe5d1b4c501a5be3041fd7cccdb50e5945ecf794dde68c058ff88a1ed918d9466636d723e117e1c073665c20d5330a3e2ad4c SHA512 5ca499866911f12338a1303be4d037b60a62e257e77856349accff7d002c5fef5f6b1f74e6558392e1ed265413440f237a6775a57ec9a57429ce480fea6f838d
diff --git a/sci-mathematics/flintqs/flintqs-1.0.ebuild b/sci-mathematics/flintqs/flintqs-1.0.ebuild
new file mode 100644
index 000000000000..676e751c8bd8
--- /dev/null
+++ b/sci-mathematics/flintqs/flintqs-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Multi-polynomial quadratic sieve for integer factorization"
+HOMEPAGE="https://github.com/sagemath/FlintQS"
+# The github tarball is missing the autotools stuff.
+SRC_URI="http://files.sagemath.org/spkg/upstream/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-libs/gmp:="
+RDEPEND="${DEPEND}"
+
+src_test() {
+ # Factor,
+ #
+ # 1000000000000000005490000000000000001989
+ #
+ # to get
+ #
+ # 10000000000000000051 * 100000000000000000039.
+ #
+ # The sed command deletes all lines up to the pattern match.
+ #
+ ACTUAL=$(echo 1000000000000000005490000000000000001989 | \
+ QuadraticSieve | \
+ sed '0,/FACTORS:/d' | \
+ sort --numeric | \
+ uniq |
+ tr '\n' ' ')
+ EXPECTED="10000000000000000051 100000000000000000039 "
+
+ [[ "${ACTUAL}" == "${EXPECTED}" ]] || die "test factorization failed"
+}
diff --git a/sci-mathematics/flintqs/metadata.xml b/sci-mathematics/flintqs/metadata.xml
new file mode 100644
index 000000000000..5fa38751016e
--- /dev/null
+++ b/sci-mathematics/flintqs/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="github">sagemath/FlintQS</remote-id>
+ </upstream>
+</pkgmetadata>