summaryrefslogtreecommitdiff
path: root/sci-mathematics/fann/fann-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/fann/fann-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/fann/fann-9999.ebuild')
-rw-r--r--sci-mathematics/fann/fann-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-mathematics/fann/fann-9999.ebuild b/sci-mathematics/fann/fann-9999.ebuild
new file mode 100644
index 000000000000..ffe0d8b9bb2d
--- /dev/null
+++ b/sci-mathematics/fann/fann-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib git-r3
+
+DESCRIPTION="Fast Artificial Neural Network Library"
+HOMEPAGE="http://leenissen.dk/fann/"
+EGIT_REPO_URI="https://github.com/libfann/fann"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="examples"
+
+src_test() {
+ cd examples || die 'fails to enter examples directory'
+ LD_LIBRARY_PATH="${BUILD_DIR}/src" GCC="$(tc-getCC) ${CFLAGS} -I../src/include -L${BUILD_DIR}/src" emake -e runtest
+ emake clean
+}
+
+src_install() {
+ cmake-multilib_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}