summaryrefslogtreecommitdiff
path: root/sci-mathematics/factmsieve
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/factmsieve
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/factmsieve')
-rw-r--r--sci-mathematics/factmsieve/Manifest6
-rw-r--r--sci-mathematics/factmsieve/factmsieve-76-r1.ebuild31
-rw-r--r--sci-mathematics/factmsieve/files/factmsieve-76.patch52
-rw-r--r--sci-mathematics/factmsieve/metadata.xml8
4 files changed, 97 insertions, 0 deletions
diff --git a/sci-mathematics/factmsieve/Manifest b/sci-mathematics/factmsieve/Manifest
new file mode 100644
index 000000000000..c0b68a0d3b06
--- /dev/null
+++ b/sci-mathematics/factmsieve/Manifest
@@ -0,0 +1,6 @@
+AUX factmsieve-76.patch 1386 SHA256 ed69d01cf81a69cf19250d216923d452d6a81184a342080eba8914a252360b28 SHA512 f2dcda3838b27d39e235875a9be7dfccf69618f73daf73d28f599a33fe428bec289f52329128179772f6fbcdaa8692df9763af75b701459f03698c768fed584f WHIRLPOOL 92f0e8f3ccf1bdcda8927626ba69d8329811051018be5d595bb03c8c880c28a30274043c571e5f06fff1a6b98666cf4dfe4725ec894bd6c047ca4b4baac50be4
+DIST factmsieve.76.zip 19563 SHA256 961db0a36acc58ebf5ce2f5ba9f952e018a9aefbc2f9f8ab8b2a425757c2e2a2 SHA512 b07b0676a635ff746b1edfaf064d27388df8f9c5c2fe1bd1e80d4c839c6e518e3a0b39a06b76f3d59c9fa3f4cc99df0831ba6309a2a7d2eb779b952a29996431 WHIRLPOOL c5d818122f5db9b744272999bb72c42eb73a35dd20ad4ce46822b7e5be2f978a6582c9c5a2402f5fc9a1db4e8ec9f5373f7b090421000f85abecec156cf97a81
+EBUILD factmsieve-76-r1.ebuild 687 SHA256 2a995823c09d6a72926028c728bb127695961dc8b6cb6bea9b9fa614524537b0 SHA512 d79cf5f87602e5ca197bff1866c97a30d1538a64423483ab6331be57dba9c090cbcba07b8424623a10374e68586dcb7b1e6f4eefd23d987cc334f8e4bb47f3e4 WHIRLPOOL 17a5ecad76f66becfaa1d330b07069be2dc29bbb33be1e9557701d92b0fc028ce278f97d1e83c6d8ba9a228b95ec63e23f33d5d4f46c747f1ce65eb16cfba483
+MISC ChangeLog 2502 SHA256 d13a388b7b1035ee6ddf7b399ded40fb1af95356ebf547cb0320caf9310d78d7 SHA512 050fa3c9761bb15761cc4f9e4dcb630cb7f0802bb5beb4b736e01af9f6a16254ba4461f442bc7a5ea727c367db0f2ebd5fa0473f7ffe09bdd4afe8fe66ec185b WHIRLPOOL ba54f9966058a27e0eb078318966e5d3c13516da964c83d5faff9b1c3bfa118e1c914db752586a5c6a55d14eb563d7e7a383d15d3ca715c4612b609341991d4f
+MISC ChangeLog-2015 512 SHA256 24f6a710fd26af62dc5ed5836b5b669bfc7811cff7e56b9c24b4aa253c117de5 SHA512 b6c731c4accdf25eabb18e80bf4dbb7803687907ec584e766b0fb5f1766d621f25afdb72e3db19eb90b7edb5049ffe01a3d187abe4afd5ab70f45014ddd707fe WHIRLPOOL 240a26985068e923c8a886b35938f4d7620098c160a7d14f6778b82d071c74f1c3dc4bd8260f855af7f068bffd581e38c35993d8b5c57a6e03b248e211f622de
+MISC metadata.xml 247 SHA256 0deec0776f26fb762fdf7711f4589b14f52a2456436ef557eec62a2cf2fb2bb7 SHA512 29cf52c16b0cce69899d9c2da8acd9144b7d760442aa323b854dceadb42459e009545193b1df7911ac2241b59f4819b4a6bb1d206d6f57953f770031433bb6b7 WHIRLPOOL a135fa622e99d3dcdb432bc6b3c366076b3d86b4bfd9a76c852d781b8e9152541c7e7a2c7c6d6a3c4d2200dce792847a08166aaf7c17c22b6299dfe868234dec
diff --git a/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild b/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild
new file mode 100644
index 000000000000..b8e607498d38
--- /dev/null
+++ b/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Convenient factorization helper script using msieve and ggnfs"
+HOMEPAGE="http://gladman.plushost.co.uk/oldsite/computing/factoring.php"
+SRC_URI="http://gladman.plushost.co.uk/oldsite/computing/${PN}.${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sci-mathematics/msieve
+ sci-mathematics/ggnfs"
+DEPEND=""
+
+S="${WORKDIR}"
+PATCHES=( "${FILESDIR}/${P}.patch" )
+
+src_install() {
+ python_fix_shebang ${PN}.py
+ dobin ${PN}.py
+}
diff --git a/sci-mathematics/factmsieve/files/factmsieve-76.patch b/sci-mathematics/factmsieve/files/factmsieve-76.patch
new file mode 100644
index 000000000000..eaf50efaecca
--- /dev/null
+++ b/sci-mathematics/factmsieve/files/factmsieve-76.patch
@@ -0,0 +1,52 @@
+--- a/factmsieve.py
++++ b/factmsieve.py
+@@ -1,3 +1,4 @@
++#!/usr/bin/env python
+ # factmsieve.py - A Python driver for GGNFS and MSIEVE
+ #
+ # Copyright (c) 2010, Brian Gladman
+@@ -56,9 +57,12 @@
+ import time, subprocess, gzip, glob, math, tempfile, datetime
+ import atexit, threading, collections, multiprocessing, platform
+
++# need to save pwd
++CUR_DIR=os.path.realpath(os.curdir)
++
+ # Set binary directory paths
+-GGNFS_PATH = '../../bin/x64/Release/'
+-MSIEVE_PATH = '../../../msieve/build.vc10/x64/Release/'
++GGNFS_PATH = '/usr/bin/'
++MSIEVE_PATH = '/usr/bin/'
+
+ # Set the number of CPU cores and threads
+ NUM_CORES = 4
+@@ -69,7 +73,7 @@
+ # number of linear algebra threads to launch
+ LA_THREADS = NUM_CORES * THREADS_PER_CORE
+
+-USE_CUDA = True
++USE_CUDA = False
+ GPU_NUM = 0
+ MSIEVE_POLY_TIME_LIMIT = 0
+
+@@ -103,8 +107,8 @@
+
+ # default parameter files
+
+-DEFAULT_PAR_FILE = GGNFS_PATH + 'def-par.txt'
+-DEFAULT_POLSEL_PAR_FILE = GGNFS_PATH + 'def-nm-params.txt'
++DEFAULT_PAR_FILE = '/usr/share/doc/ggnfs/def-par.txt'
++DEFAULT_POLSEL_PAR_FILE = '/usr/share/doc/ggnfs/def-nm-params.txt'
+
+ # temporary files
+
+@@ -258,7 +262,8 @@
+ # write string to log(s):
+
+ def write_string_to_log(s):
+- with open(LOGNAME, 'a') as out_f:
++ # XXX hax
++ with open(CUR_DIR+'/'+LOGNAME, 'a') as out_f:
+ print(date_time_string() + s, file = out_f)
+
+ def output(s, console = True, log = True):
diff --git a/sci-mathematics/factmsieve/metadata.xml b/sci-mathematics/factmsieve/metadata.xml
new file mode 100644
index 000000000000..40aa45df2b01
--- /dev/null
+++ b/sci-mathematics/factmsieve/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>