summaryrefslogtreecommitdiff
path: root/sci-mathematics/eclib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /sci-mathematics/eclib
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'sci-mathematics/eclib')
-rw-r--r--sci-mathematics/eclib/Manifest2
-rw-r--r--sci-mathematics/eclib/eclib-20220621.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index 8d0e954adcb8..41af80cf1b94 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1,3 +1,5 @@
DIST eclib-20210625.tar.bz2 921173 BLAKE2B 8ecfde35fd6e557601c0a4e5f877ec49e355dbd5bb4248256c89b1160406992f59568db1060a835bad482d6ba4f1f0cc7719af5f03ecdc79abbe2ca0c9ed713e SHA512 a1319e91790decbc5219e02edbad5b86a6d3e5400bec3a9a9f2c60b89d340a0b915458f93c86f63d21c4b72995aa5fe65e0b5346241f297fe54ba2d3fc183ae3
+DIST eclib-20220621.tar.bz2 921610 BLAKE2B f53f0648f09e427ae9b208a17c93f9808c2ab859cc41db6b5acb3b1382e9aaee93b17cd9d94c14e7f4941f140749d91b2ad94ad684f8a2c0f6033ac042cc89e7 SHA512 45cc47256f6ccbf2a00711d14533cffe8a3fc0dfea3d94d9823ac43af8a56cfe95485f0559c9141203910e85b1d3fa3284ee12ca5e53d083b74cbb2907afca42
EBUILD eclib-20210625.ebuild 868 BLAKE2B 29b76a0f676f8ec04df6ff8e145799411466740c388645333966c38d26f703878561cbe3a9eb10200799e4897f037bf6a9f8a6f9b72fde1a86e11132fa5b14d1 SHA512 387a22c5d13c847725e350e25fc0679ab1108ed1f564311c5a6b78849241bc45fce0fb30c966e53d827c951bcb23749e1626e72fda58024a9f7cdac55802f3bd
+EBUILD eclib-20220621.ebuild 871 BLAKE2B 657e8fd2208a6fcbce3c39b3743ba54ba434bdd2d416b53867677389da1ec144207b1549011169ce3edd1423ee18077ebfe96ecd796ad43e007474da96b52316 SHA512 22d070bbb255b6cad1dfac75db07c3c582fb64eb71331428fc599e2c5d678bd902e84dd7f557bcab5cdda1eff482f7126ae833dbff0f7fb7ce2b15af826ef973
MISC metadata.xml 1089 BLAKE2B d10f9af5634478f0f13595abd10d9eefc437c27955cd3f504165beb4219e55c3997f16271148c1c2fbb5c9ae71e08665000836658bb954b83db06aeffa2b4098 SHA512 7111f3231464624d356611372934d0604fdd7a05c3531342a372979292a068dfa2edf49c4de5840cbf07b6f4819c22b8d87d54d7cacefb28ce0f53576d4620fd
diff --git a/sci-mathematics/eclib/eclib-20220621.ebuild b/sci-mathematics/eclib/eclib-20220621.ebuild
new file mode 100644
index 000000000000..b929d5e52f1c
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20220621.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+# Major version of /usr/lib64/libec.so
+SLOT="0/10"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}