summaryrefslogtreecommitdiff
path: root/sci-mathematics/eclib/eclib-20190909.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-mathematics/eclib/eclib-20190909.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-mathematics/eclib/eclib-20190909.ebuild')
-rw-r--r--sci-mathematics/eclib/eclib-20190909.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/eclib-20190909.ebuild b/sci-mathematics/eclib/eclib-20190909.ebuild
new file mode 100644
index 000000000000..e30f083b9992
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20190909.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://www.warwick.ac.uk/~masgaj/mwrank/index.html"
+
+# We use the SageMath tarball instead of the one from github because
+# the github releases don't contain the "make dist" stuff and we would
+# need autotools.eclass to generate it.
+SRC_URI="http://files.sagemath.org/spkg/upstream/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="boost flint minimal static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint) \
+ $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}