summaryrefslogtreecommitdiff
path: root/sci-mathematics/easycrypt/easycrypt-2022.04_p20230324.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-02 05:16:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-02 05:16:35 +0100
commit6882d8d1110ef4feeec532196a1f0a25420d0fd1 (patch)
treec8a3d28a31e6c077d6b9097ff36b1232d2ce04b7 /sci-mathematics/easycrypt/easycrypt-2022.04_p20230324.ebuild
parent85a2a2153ef8027c2ba1be45143cd91914be0ad0 (diff)
gentoo auto-resync : 02:04:2023 - 05:16:35
Diffstat (limited to 'sci-mathematics/easycrypt/easycrypt-2022.04_p20230324.ebuild')
-rw-r--r--sci-mathematics/easycrypt/easycrypt-2022.04_p20230324.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-mathematics/easycrypt/easycrypt-2022.04_p20230324.ebuild b/sci-mathematics/easycrypt/easycrypt-2022.04_p20230324.ebuild
new file mode 100644
index 000000000000..8434aa25bbc1
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-2022.04_p20230324.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ if [[ ${PV} == *_p20230324 ]] ; then
+ COMMIT=f62625928cc0970c88839c84897d1f6b17437519
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ fi
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ >=sci-mathematics/why3-1.6:= <sci-mathematics/why3-1.7:=
+ dev-ml/batteries:=
+ dev-ml/camlp-streams:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}