summaryrefslogtreecommitdiff
path: root/sci-mathematics/dunshire/dunshire-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
commit490ef2c2dc8b4e808f37add1adee21a754efd9a9 (patch)
treee235cdf15550b3d2f644b6fc4a8aa726971416f5 /sci-mathematics/dunshire/dunshire-0.1.3.ebuild
parentda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (diff)
gentoo auto-resync : 21:04:2024 - 12:05:28
Diffstat (limited to 'sci-mathematics/dunshire/dunshire-0.1.3.ebuild')
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-mathematics/dunshire/dunshire-0.1.3.ebuild b/sci-mathematics/dunshire/dunshire-0.1.3.ebuild
new file mode 100644
index 000000000000..ac63ace2d98f
--- /dev/null
+++ b/sci-mathematics/dunshire/dunshire-0.1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python library to solve linear games over symmetric cones"
+HOMEPAGE="https://michael.orlitzky.com/code/dunshire/"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
+DOCS=( doc/README.rst )
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests setup.py
+
+python_test() {
+ esetup.py test
+}