summaryrefslogtreecommitdiff
path: root/sci-mathematics/dsfmt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-mathematics/dsfmt
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-mathematics/dsfmt')
-rw-r--r--sci-mathematics/dsfmt/Manifest3
-rw-r--r--sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild36
-rw-r--r--sci-mathematics/dsfmt/metadata.xml25
3 files changed, 64 insertions, 0 deletions
diff --git a/sci-mathematics/dsfmt/Manifest b/sci-mathematics/dsfmt/Manifest
new file mode 100644
index 000000000000..31d6b57486e1
--- /dev/null
+++ b/sci-mathematics/dsfmt/Manifest
@@ -0,0 +1,3 @@
+DIST dsfmt-2.2.4.tar.gz 4984255 BLAKE2B 6119445d93cb45faab28dfb52a18c07cd5703b243b3cddde35fff7a5e948fa8788dfe8428ae8e0a52604f91ac07fe7b3bb0f6c438ef93b5257b42baee9dfdec5 SHA512 fe84e986cbf198172340adfac0436b08f087643eca3f1ceccacde146cbfd8c41e3eb0dfbb062f7ca5f462db13c386abd7c269bc0cbefc9a0ecf97a8a8870a2e4
+EBUILD dsfmt-2.2.4.ebuild 827 BLAKE2B 77b57fff30b2f5683925b10f9c28459e35529be12cdd450ab0cb3ea84e568ae2d41364e18193a035b31f48f77363aaa6eae57ed4bb8b6c1faada28808430dd37 SHA512 e5b0cd957e026cbd37ecdb168f73a86da3c6929b2a83f8fff5ca28630af9c6e224ce9a630d940c1c80a2096aed112c84e60f7d122a402eba0975a84759f2a2ac
+MISC metadata.xml 1021 BLAKE2B 8d0c65e23ff53a99a6df4e2bc3c43c9289cc6e4ac979a03f03ab6d80c44c8cf0eefd40e7d8fb91410ee5a41c774a48f34e533b477ab34a5ee07cda1fbff2828a SHA512 e2e66fd22d2374db3cb4bb8c48978acd02d15ef9a760c93ca5e2f4c1b530f4d7d7ac08759830d9a4f53d1d359bcc316328e6283ab0c317e34a3ef8280539c4c1
diff --git a/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild b/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild
new file mode 100644
index 000000000000..5de399e78f8a
--- /dev/null
+++ b/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MYPN=dSFMT
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Double precision SIMD-oriented Fast Mersenne Twister library"
+HOMEPAGE="http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT"
+SRC_URI="https://github.com/MersenneTwister-Lab/dSFMT/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${MYP}"
+
+soname="lib${MYPN}.so"
+
+src_compile() {
+ emake CCFLAGS="${CFLAGS}"
+ $(tc-getCC) -fPIC -shared -DDSFMT_SHLIB -DDSFMT_DO_NOT_USE_OLD_NAMES ${LDFLAGS} ${CFLAGS} -Wl,-soname=${soname} -o ${soname} ${MYPN}.c || die
+}
+
+src_test() {
+ emake std-check
+}
+
+src_install() {
+ doheader dSFMT.c d*.h
+ dodoc README*txt CHANGE*
+ dolib.so ${soname}
+}
diff --git a/sci-mathematics/dsfmt/metadata.xml b/sci-mathematics/dsfmt/metadata.xml
new file mode 100644
index 000000000000..2a2a3a3027f6
--- /dev/null
+++ b/sci-mathematics/dsfmt/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>jeffrey@icurse.nl</email>
+ <name>Jeffrey Lin</name>
+ </maintainer>
+ <maintainer type="person" proxied="proxy">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <longdescription lang="en">
+ The purpose of Double precision SIMD-oriented Fast Mersenne Twister (dSFMT)
+ is to speed up the generation by avoiding the expensive conversion
+ of integer to double (floating point). dSFMT directly generates
+ double precision floating point pseudorandom numbers which have the
+ IEEE Standard for Binary Floating-Point Arithmetic (ANSI/IEEE Std
+ 754-1985) format. dSFMT is only available on the CPUs which use IEEE
+ 754 format double precision floating point numbers.
+ </longdescription>
+</pkgmetadata>