summaryrefslogtreecommitdiff
path: root/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild')
-rw-r--r--sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild b/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild
new file mode 100644
index 000000000000..5de399e78f8a
--- /dev/null
+++ b/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MYPN=dSFMT
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Double precision SIMD-oriented Fast Mersenne Twister library"
+HOMEPAGE="http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT"
+SRC_URI="https://github.com/MersenneTwister-Lab/dSFMT/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${MYP}"
+
+soname="lib${MYPN}.so"
+
+src_compile() {
+ emake CCFLAGS="${CFLAGS}"
+ $(tc-getCC) -fPIC -shared -DDSFMT_SHLIB -DDSFMT_DO_NOT_USE_OLD_NAMES ${LDFLAGS} ${CFLAGS} -Wl,-soname=${soname} -o ${soname} ${MYPN}.c || die
+}
+
+src_test() {
+ emake std-check
+}
+
+src_install() {
+ doheader dSFMT.c d*.h
+ dodoc README*txt CHANGE*
+ dolib.so ${soname}
+}