summaryrefslogtreecommitdiff
path: root/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/diagrtb/diagrtb-2.64.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/diagrtb/diagrtb-2.64.ebuild')
-rw-r--r--sci-mathematics/diagrtb/diagrtb-2.64.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
new file mode 100644
index 000000000000..7d68ff7897a9
--- /dev/null
+++ b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Calculation of some eigenvectors of a large real, symmetrical, matrix"
+HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
+SRC_URI="http://ecole.modelisation.free.fr/rtb2011.tar.gz -> ${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+RESTRICT="mirror bindist"
+
+S="${WORKDIR}"/Source_RTB2011
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DEXAMPLES=$(usex examples)
+ )
+
+ cmake-utils_src_configure
+}