summaryrefslogtreecommitdiff
path: root/sci-mathematics/cryptominisat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sci-mathematics/cryptominisat
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sci-mathematics/cryptominisat')
-rw-r--r--sci-mathematics/cryptominisat/Manifest3
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild41
-rw-r--r--sci-mathematics/cryptominisat/metadata.xml20
3 files changed, 64 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/Manifest b/sci-mathematics/cryptominisat/Manifest
new file mode 100644
index 000000000000..2fe9f833da46
--- /dev/null
+++ b/sci-mathematics/cryptominisat/Manifest
@@ -0,0 +1,3 @@
+DIST cryptominisat-5.8.0.tar.gz 943785 BLAKE2B 534af88a8432c7e3da63989cad8fd5e1491bd69a80b44977fa681e0356e857a505a82dc860b0d04d07987e3edae2861da67ec9dd781261e03a1120dc342b9759 SHA512 3eb954f01524b189a8de57a05f6060471a083addc4b9077c1e32b769d26393ce3d33468819ba8169deedce43fc3663b0ad8bbad95c6afe5e562e438c57b75496
+EBUILD cryptominisat-5.8.0.ebuild 920 BLAKE2B b22d56c5e175d44acb483b1b684cd0236b7f517337c627fde15aa92ee7cb6e69942751e6e8ff6fe66cd40be83eb1144502b0e9d7b094910dafae3faaf182196b SHA512 209995f8551665b615c3a23b50d59fc2ff41f7b57ffbe5570521a67a06f38ef8a9a9cda4faf3465b05c8b05f4da31337c95c12eeb40fdce1e27e7a6e18f9a6b8
+MISC metadata.xml 858 BLAKE2B 4543d51cedd7b5e5e8508c14dfae420360f9d76ada1b969d855ca2b17b2c967036b29a9f2769a2c78e736c1e449e2b079558cd7460a72d402e9f1ce029ba414a SHA512 e1b39d888ab6c09f8707a164c7f683831a908477b2c7f219f4c9f71161ba84c145836ca2b1665e200f15a6e2ff6ca6318bd16fc40d57ad9c64bd1a4e229fbabc
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild
new file mode 100644
index 000000000000..d4517fca935e
--- /dev/null
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit python-single-r1 cmake
+
+DESCRIPTION="Advanced SAT solver with C++ and Python interfaces"
+HOMEPAGE="https://github.com/msoos/cryptominisat/"
+SRC_URI="https://github.com/msoos/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2 MIT"
+IUSE="+python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test" # tests require many convoluted bundled (git) modules
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DNOBREAKID=ON
+ -DNOM4RI=ON
+ -DENABLE_PYTHON_INTERFACE=$(usex python)
+ -DFORCE_PYTHON3=$(usex python)
+ -DENABLE_TESTING=OFF
+ )
+ cmake_src_configure
+}
diff --git a/sci-mathematics/cryptominisat/metadata.xml b/sci-mathematics/cryptominisat/metadata.xml
new file mode 100644
index 000000000000..694a2c352cda
--- /dev/null
+++ b/sci-mathematics/cryptominisat/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ This system provides CryptoMiniSat, an advanced incremental SAT solver.
+ The system has 3 interfaces: command-line, C++ library and python.
+ The command-line interface takes a cnf as an input in the DIMACS format
+ with the extension of XOR clauses. The C++ and python interface mimics this
+ and also allows for incremental use: assumptions and multiple solve calls.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/msoos/cryptominisat/issues/</bugs-to>
+ <remote-id type="github">msoos/cryptominisat</remote-id>
+ </upstream>
+</pkgmetadata>