summaryrefslogtreecommitdiff
path: root/sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 19:30:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 19:30:41 +0100
commit6fe5af3f06c92a6b1a6b21ff5e1bc9d107490971 (patch)
tree872ff7ba355a0b1735779b329c6a6b8b8f728a88 /sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild
parente564f1661521043bc9e03e613c3cd8c79d5d7713 (diff)
gentoo auto-resync : 25:06:2023 - 19:30:41
Diffstat (limited to 'sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild')
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild
new file mode 100644
index 000000000000..4d4e2a5c0742
--- /dev/null
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Advanced SAT solver with C++ and command-line interfaces"
+HOMEPAGE="https://github.com/msoos/cryptominisat/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/msoos/${PN}.git"
+else
+ SRC_URI="https://github.com/msoos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="0/${PV}"
+LICENSE="GPL-2 MIT"
+RESTRICT="test" # Tests require many git modules.
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DNOBREAKID=ON
+ -DNOM4RI=ON
+ -DENABLE_TESTING=OFF
+ )
+ cmake_src_configure
+}