summaryrefslogtreecommitdiff
path: root/sci-mathematics/coq-mathcomp/coq-mathcomp-1.14.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-07 16:36:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-07 16:36:21 +0100
commit4f49fc7caa0253a7ab164331f55bd4c70bba1bf7 (patch)
treea54fc9fe9ce5d43bee554b0c4ef7c26fb45e72d6 /sci-mathematics/coq-mathcomp/coq-mathcomp-1.14.0-r1.ebuild
parenta0e773d57146b0a0ec25567af504a10e6f187811 (diff)
gentoo auto-resync : 07:09:2022 - 16:36:21
Diffstat (limited to 'sci-mathematics/coq-mathcomp/coq-mathcomp-1.14.0-r1.ebuild')
-rw-r--r--sci-mathematics/coq-mathcomp/coq-mathcomp-1.14.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-mathematics/coq-mathcomp/coq-mathcomp-1.14.0-r1.ebuild b/sci-mathematics/coq-mathcomp/coq-mathcomp-1.14.0-r1.ebuild
new file mode 100644
index 000000000000..fcf362d97248
--- /dev/null
+++ b/sci-mathematics/coq-mathcomp/coq-mathcomp-1.14.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Mathematical Components for the Coq proof assistant"
+HOMEPAGE="https://github.com/math-comp/math-comp/"
+SRC_URI="https://github.com/math-comp/math-comp/archive/mathcomp-${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/math-comp-mathcomp-${PV}/mathcomp
+
+LICENSE="CeCILL-B"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+
+RDEPEND=">=sci-mathematics/coq-8.13.0:= <sci-mathematics/coq-8.16.0:="
+DEPEND="${RDEPEND}"
+
+# > make jobserver unavailable
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake -j1 install DESTDIR="${D}"
+}