summaryrefslogtreecommitdiff
path: root/sci-mathematics/btor2tools/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-11 05:43:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-11 05:43:34 +0000
commitad391b961414c99124b93cb86695c04bd8d57937 (patch)
tree446151aff1c09db21505a46da4107f9a5be588e0 /sci-mathematics/btor2tools/files
parent113cc6fe7a9adc2baf67f9ef7723db6ed2b24887 (diff)
gentoo auto-resync : 11:01:2023 - 05:43:34
Diffstat (limited to 'sci-mathematics/btor2tools/files')
-rw-r--r--sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch28
-rw-r--r--sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-clfags.patch19
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch b/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch
new file mode 100644
index 000000000000..061ddac84194
--- /dev/null
+++ b/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch
@@ -0,0 +1,28 @@
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1,4 +1,5 @@
+ add_library(btor2parser
++ SHARED
+ btor2parser/btor2parser.c
+ )
+ target_include_directories(btor2parser PRIVATE .)
+@@ -10,6 +11,19 @@ install(
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ )
+
++add_library(btor2parser_static
++ STATIC
++ btor2parser/btor2parser.c
++)
++target_include_directories(btor2parser_static PRIVATE .)
++set_target_properties(btor2parser_static PROPERTIES OUTPUT_NAME btor2parser)
++set_target_properties(btor2parser_static PROPERTIES PUBLIC_HEADER btor2parser/btor2parser.h)
++install(
++ TARGETS btor2parser_static
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
++)
++
+ add_executable(btorsim
+ btorsim/btorsimam.cpp
+ btorsim/btorsimstate.cpp
diff --git a/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-clfags.patch b/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-clfags.patch
new file mode 100644
index 000000000000..84c6631c9219
--- /dev/null
+++ b/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-clfags.patch
@@ -0,0 +1,19 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -91,16 +91,6 @@ add_check_c_cxx_flag("-Wredundant-decls")
+ add_check_c_flag("-std=gnu99")
+ add_required_cxx_flag("-std=gnu++11")
+
+-if(CMAKE_BUILD_TYPE STREQUAL "Debug")
+- add_check_c_cxx_flag("-g3")
+- add_check_c_cxx_flag("-ggdb")
+-else()
+- add_check_c_cxx_flag("-O3")
+- if(NOT CHECK)
+- add_check_c_cxx_flag("-DNDEBUG")
+- endif()
+-endif()
+-
+ if(ASAN)
+ # -fsanitize=address requires CMAKE_REQUIRED_FLAGS to be explicitely set,
+ # otherwise the -fsanitize=address check will fail while linking.