summaryrefslogtreecommitdiff
path: root/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-03 03:56:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-03 03:56:37 +0000
commit54e9f9704b37e05c561eadb37d89d30ee7dda9ee (patch)
treebb03a8b10fc448608096c5e872d62b366fc2c93c /sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild
parent1615d14d4de4360b2241ce5cd8a84157cc86cde0 (diff)
gentoo auto-resync : 03:11:2023 - 03:56:37
Diffstat (limited to 'sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild')
-rw-r--r--sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild b/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild
index 58780bf5c440..c2cee9e4d4ea 100644
--- a/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild
+++ b/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild
@@ -3,20 +3,22 @@
EAPI=8
-[[ ${PV} == *_pre20220518 ]] && COMMIT=b8456dda4780789e882f5791eb486f295ade4da4
-
inherit cmake
DESCRIPTION="Generic parser and tools for the BTOR2 format"
HOMEPAGE="https://github.com/Boolector/btor2tools/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/Boolector/${PN}.git"
else
+ [[ "${PV}" == *_pre20220518 ]] && COMMIT=b8456dda4780789e882f5791eb486f295ade4da4
+
SRC_URI="https://github.com/Boolector/${PN}/archive/${COMMIT}.tar.gz
-> ${P}.tar.gz"
- S="${WORKDIR}"/${PN}-${COMMIT}
+ S="${WORKDIR}/${PN}-${COMMIT}"
+
KEYWORDS="~amd64 ~x86"
fi
@@ -24,13 +26,16 @@ LICENSE="MIT"
SLOT="0"
IUSE="examples"
-PATCHES=( "${FILESDIR}"/${P}-cmake-clfags.patch )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0_pre20220518-btorsplit-cstdint.patch"
+ "${FILESDIR}/${PN}-1.0.0_pre20220518-cmake-clfags.patch"
+)
src_install() {
cmake_src_install
if use examples ; then
- insinto /usr/share/${PN}
+ insinto "/usr/share/${PN}"
dodoc -r examples
fi
}