summaryrefslogtreecommitdiff
path: root/sci-mathematics/alt-ergo/alt-ergo-2.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-mathematics/alt-ergo/alt-ergo-2.3.0-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-mathematics/alt-ergo/alt-ergo-2.3.0-r1.ebuild')
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-2.3.0-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-mathematics/alt-ergo/alt-ergo-2.3.0-r1.ebuild b/sci-mathematics/alt-ergo/alt-ergo-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..6dbe4ce6fc63
--- /dev/null
+++ b/sci-mathematics/alt-ergo/alt-ergo-2.3.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Automatic theorem prover"
+HOMEPAGE="https://alt-ergo.ocamlpro.com"
+SRC_URI="https://alt-ergo.ocamlpro.com/http/${P}/${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="examples gtk +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.09.0:=[ocamlopt=]
+ dev-ml/zarith:=
+ dev-ml/lablgtk:2=[sourceview,ocamlopt=]
+ dev-ml/camlzip:=
+ sci-mathematics/psmt2-frontend
+ >=dev-ml/ocplib-simplex-0.4:=
+ >=dev-ml/menhir-20181006:=
+ dev-ml/seq:=
+ dev-ml/dune:=
+ dev-ml/num:="
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES INSTALL.md README.md )
+
+QA_FLAGS_IGNORED=(
+ /usr/lib64/alt-ergo-parsers/AltErgoParsers.cmxs
+ /usr/lib64/alt-ergo-lib/AltErgoLib.cmxs
+ /usr/bin/alt-ergo
+)
+
+src_prepare() {
+ default
+ find "${S}" -name \*.ml | xargs sed -i "s:Pervasives:Stdlib:g" || die
+}
+
+src_configure() {
+ ./configure --prefix /usr --libdir=/usr/$(get_libdir)
+}
+
+src_compile() {
+ emake lib
+ emake bin
+ use gtk && emake gui
+}
+
+src_install() {
+ default
+ use gtk && emake DESTDIR="${D}" install-gui
+ use examples && dodoc -r examples
+ mv "${D}"/usr/doc/* "${D}"/usr/share/doc/${PF}/ || die
+ rmdir "${D}"/usr/doc || die
+}