summaryrefslogtreecommitdiff
path: root/sci-mathematics/alectryon/alectryon-1.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-mathematics/alectryon/alectryon-1.4.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-mathematics/alectryon/alectryon-1.4.0.ebuild')
-rw-r--r--sci-mathematics/alectryon/alectryon-1.4.0.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/sci-mathematics/alectryon/alectryon-1.4.0.ebuild b/sci-mathematics/alectryon/alectryon-1.4.0.ebuild
new file mode 100644
index 000000000000..bdbf53a0c35b
--- /dev/null
+++ b/sci-mathematics/alectryon/alectryon-1.4.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit elisp-common distutils-r1
+
+DESCRIPTION="Toolkit for literate programming in Coq"
+HOMEPAGE="https://github.com/cpitclaudel/alectryon/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cpitclaudel/${PN}.git"
+else
+ SRC_URI="https://github.com/cpitclaudel/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc emacs"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/myst_parser[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ sci-mathematics/coq-serapi
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ emacs? (
+ >=app-editors/emacs-23.1:*
+ app-emacs/flycheck
+ app-emacs/proofgeneral
+ )
+"
+
+DOCS=( CHANGES.rst CITATION.bib README.rst )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ python_foreach_impl distutils-r1_python_compile
+
+ use doc && emake -C ./recipes/sphinx latexpdf
+ use emacs && elisp-compile ./etc/elisp/alectryon.el
+}
+
+src_install() {
+ python_foreach_impl distutils-r1_python_install
+ einstalldocs
+
+ if use doc ; then
+ docinto html
+ dodoc ./recipes/sphinx/_build/html/*
+ docinto pdf
+ dodoc ./recipes/sphinx/_build/latex/alectryon-demo.pdf
+ docinto latex
+ dodoc ./recipes/sphinx/_build/latex/alectryon-demo.tex
+ fi
+ if use emacs ; then
+ elisp-install ${PN} ./etc/elisp/${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}