summaryrefslogtreecommitdiff
path: root/sci-mathematics/Macaulay2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-03 16:17:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-03 16:17:22 +0000
commit4cd2370bed609c118b6edfde5d3f116e5c35b897 (patch)
treeec58f2c41f49754e41521d5ebc9dce4597ddd0a5 /sci-mathematics/Macaulay2
parentf443475c824b4b5c086e6d040961cb35ad81bc60 (diff)
gentoo resync : 03.12.2017
Diffstat (limited to 'sci-mathematics/Macaulay2')
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-1.7_pre.ebuild153
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-1.8.2.1-r1.ebuild2
-rw-r--r--sci-mathematics/Macaulay2/Manifest8
-rw-r--r--sci-mathematics/Macaulay2/files/1.6-lapack.patch50
4 files changed, 2 insertions, 211 deletions
diff --git a/sci-mathematics/Macaulay2/Macaulay2-1.7_pre.ebuild b/sci-mathematics/Macaulay2/Macaulay2-1.7_pre.ebuild
deleted file mode 100644
index 4b4e620d27db..000000000000
--- a/sci-mathematics/Macaulay2/Macaulay2-1.7_pre.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools elisp-common eutils flag-o-matic python-single-r1 toolchain-funcs
-
-FACTORY="factory-4.0.0+m4"
-FACTORY_GFTABLES="factory.4.0.1-gftables"
-
-DESCRIPTION="Research tool for commutative algebra and algebraic geometry"
-HOMEPAGE="http://www.math.uiuc.edu/Macaulay2/"
-BASE_URI="http://www.math.uiuc.edu/Macaulay2/Downloads/OtherSourceCode/trunk"
-SRC_URI="
- https://dev.gentoo.org/~tomka/files/${P}.tar.bz2
- ${BASE_URI}/${FACTORY}.tar.gz
- ${BASE_URI}/${FACTORY_GFTABLES}.tar.gz
- ${BASE_URI}/gtest-1.7.0.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 x86"
-IUSE="debug emacs +optimization"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- sys-process/time
- virtual/pkgconfig"
-
-RDEPEND="${PYTHON_DEPS}
- sys-libs/gdbm
- <dev-libs/ntl-7
- sci-mathematics/pari[gmp]
- >=sys-libs/readline-6.1
- dev-libs/libxml2:2
- sci-mathematics/flint[gc]
- sci-mathematics/frobby
- sci-mathematics/4ti2
- sci-mathematics/nauty
- >=sci-mathematics/normaliz-2.8
- sci-mathematics/gfan
- sci-libs/mpir[cxx]
- dev-libs/mpfr
- sci-libs/cdd+
- sci-libs/cddlib
- sci-libs/lrslib[gmp]
- virtual/blas
- virtual/lapack
- dev-util/ctags
- sys-libs/ncurses
- >=dev-libs/boehm-gc-7.4[threads]
- dev-libs/libatomic_ops
- emacs? ( virtual/emacs )"
-
-SITEFILE=70Macaulay2-gentoo.el
-
-S="${WORKDIR}/M2/"
-
-pkg_setup () {
- tc-export CC CPP CXX PKG_CONFIG
- append-cppflags "-I/usr/include/frobby"
- # gtest needs python:2
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # Patching .m2 files to look for external programs in
- # /usr/bin
- epatch "${FILESDIR}"/1.6-paths-of-external-programs.patch
-
- # Shortcircuit lapack tests
- epatch "${FILESDIR}"/1.6-lapack.patch
-
- # Factory is a statically linked library which (in this flavor) are not used by any
- # other program. We build it internally and don't install it.
- cp "${DISTDIR}/${FACTORY}.tar.gz" "${S}/BUILD/tarfiles/" \
- || die "copy failed"
- cp "${DISTDIR}/${FACTORY_GFTABLES}.tar.gz" "${S}/BUILD/tarfiles/" \
- || die "copy failed"
- # Macaulay2 developers want that gtest is built internally because
- # the documentation says it may fail if build with options not the
- # same as the tested program.
- cp "${DISTDIR}/gtest-1.7.0.tar.gz" "${S}/BUILD/tarfiles/" \
- || die "copy failed"
-
- eautoreconf
-}
-
-src_configure (){
- # Recommended in bug #268064 Possibly unecessary
- # but should not hurt anybody.
- if ! use emacs; then
- tags="ctags"
- fi
-
- # configure instead of econf to enable install with --prefix
- ./configure LIBS="$($(tc-getPKG_CONFIG) --libs lapack)" \
- --prefix="${D}/usr" \
- --disable-encap \
- --disable-strip \
- --with-issue=Gentoo \
- $(use_enable optimization optimize) \
- $(use_enable debug) \
- --enable-build-libraries="factory" \
- --with-unbuilt-programs="4ti2 gfan normaliz nauty cddplus lrslib" \
- || die "failed to configure Macaulay"
-}
-
-src_compile() {
- # Parallel build not supported yet
- emake IgnoreExampleErrors=true -j1
-
- if use emacs; then
- cd "${S}/Macaulay2/emacs" || die
- elisp-compile *.el
- fi
-}
-
-src_test() {
- # No parallel tests yet & Need to increase the time
- # limit for long running tests in Schubert2 to pass
- emake TLIMIT=550 -j1 check
-}
-
-src_install () {
- # Parallel install not supported yet
- emake IgnoreExampleErrors=true -j1 install
-
- # Remove emacs files and install them in the
- # correct place if use emacs
- rm -rf "${ED}"/usr/share/emacs/site-lisp || die
- if use emacs; then
- cd "${S}/Macaulay2/emacs" || die
- elisp-install ${PN} *.elc *.el
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- if use emacs; then
- elisp-site-regen
- elog "If you want to set a hot key for Macaulay2 in Emacs add a line similar to"
- elog "(global-set-key [ f12 ] 'M2)"
- elog "in order to set it to F12 (or choose a different one)."
- fi
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/Macaulay2/Macaulay2-1.8.2.1-r1.ebuild b/sci-mathematics/Macaulay2/Macaulay2-1.8.2.1-r1.ebuild
index 0836337b8d5d..acd1d0deb899 100644
--- a/sci-mathematics/Macaulay2/Macaulay2-1.8.2.1-r1.ebuild
+++ b/sci-mathematics/Macaulay2/Macaulay2-1.8.2.1-r1.ebuild
@@ -18,7 +18,7 @@ SRC_URI="
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm ~x86"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="debug emacs +optimization"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/sci-mathematics/Macaulay2/Manifest b/sci-mathematics/Macaulay2/Manifest
index acef1c494f5b..71814e47d464 100644
--- a/sci-mathematics/Macaulay2/Manifest
+++ b/sci-mathematics/Macaulay2/Manifest
@@ -1,12 +1,6 @@
-AUX 1.6-lapack.patch 1849 BLAKE2B 3420f358da56c05dd65e547e000ef6dcc5faf058cf53ea79c3fee244e8d0c21c35c581e33e286fd78d6f85643d6f0a827e6de756e4da727796f7f5c18b3982b1 SHA512 89221bf3495f84b0f8f12046dcc3f85f3062c8637d2b42a37817ccef84762ffe31457d2b607457a6a3c23a50f196789d7ca6421e1078191f72bd7e08f46bd36d
AUX 1.6-paths-of-external-programs.patch 3767 BLAKE2B 01c974baf0dbf8246eb3c8aa747f0fc5dc02853fa28fdef417deffb56f8a1af9919ba50f9fcaa42ed575c90761519b6239e9544f8600b1f086d8215ca466a9ae SHA512 556944da47742a3c4539e084bb6dab7c2375733eb4cbe4d14e1dea852bba3ac61e5f6ad5f805958a52d371a918c8672f7f0308c7c0454a502ca61bb59fea6bf5
AUX 70Macaulay2-gentoo.el 597 BLAKE2B 58de58a469874a24be539fc104d829304d58237b1780dff5b61e6e5a497b150a0e4b342e797ab33de7d22ca58b93cbfd50f41057749fb6f3f84083eec4bb2d24 SHA512 2d6b6d3c85ca93bf4d4100f2172013074dec83f8ce067af219b026ca2b495ff1aa7fb3da027b64ef8e55ad431ce5d42bffdad1ab474bb3e95240ac4235f2f986
AUX Macaulay2-1.8.2.1-lapack.patch 1836 BLAKE2B 6464d859336d16fffcb8bc1aaed9442a258429e9e325118cc1d55944fe851c0a531da3fca3f57849341066167b3c1a768051b78c25763ca958b90de27061fb34 SHA512 d3d13a67daeda87753c7c4daf888d2982109cb13bc0b88be46c2dd4993715077cf0ce5e155876bf5aaf51c886ce348df550184ade4af71e7143c2c2eb16c3b7f
-DIST Macaulay2-1.7_pre.tar.bz2 4639477 SHA256 b14918187724f8911bc50edf87c9692209ff0c2191feb257084adc87609eb1cd SHA512 e70376d1e54b6e239ebb3bf676507a2115fdf5c4fbe05f320553029a84114b74d78f54e4d1bdc7643131f3c45c301e83c21ff99e4d4b675372e971368398d6f5 WHIRLPOOL 396311aadb8a7845deaee5aeca49c431430abc46201e935ef72c4579c9cbe6cd4da85f3e09ff0fe647031f8050fb7c62f63ecce251bf34648c1848cd00eef68e
DIST Macaulay2-1.8.2.1-fat.tar.bz2 26102483 SHA256 11e13fbb4aeeddae1547ed01e499e3f8961446cb9bec8b3162b29cadd2f280c1 SHA512 64f7ea9b01cdb308023a55d8ab8bd6733540f25161dacf27052c071e143418c68c639d5115cf32540c11594b70eae14473f4ef6ce5bd12b6df0722da7c13dd2c WHIRLPOOL 3f9c838d6624f95076957743bf402236708cb2af15b84d24c4446fb193f7608698cc63e43eb8eff8bf878963ce2a9fd85f37128f73d1dbd43d4c0bcda980753d
-DIST factory-4.0.0+m4.tar.gz 4711126 SHA256 9b2498cc7fc6765f1c586e8061ebe236cdce4b32a44721a235ad2644ec3124fb SHA512 1dacb9aae52e655bccbbc960397b02351050791594dd9c39771f0da7f8c6e8130a8827c2a675c3fbaaa214606e123ac9776e1c73d143649353cefc50cadeea3e WHIRLPOOL 47c4d6261fc6cc9c172035d8774f0cde9fa669fa164fc4a0f47e84ba789d69d14f5a16d042451564412fdedddec71335714ad751508495c22cea25b69f10b925
-DIST factory.4.0.1-gftables.tar.gz 2974152 SHA256 9cd158ceb1c2b1c47bdca2c0b004bba92cb0e0aaa0ea6a43ca784ebdce10eebd SHA512 060c58fe6e4565dd5e7649bfa070f14dec3c383a55ebab52a9f02b58a6405e2183e0c7e08964cddb87b81e872c0d8a52d7bd4575d07269547be544cf6a725a76 WHIRLPOOL a721a6824681118578c7289cea77a3f47e5c7654f30dc454eaac76b19cc89e416ae54b8d21a69f897d7087d4b67990634fc960f81df2ea53f428868d608dc9c2
-DIST gtest-1.7.0.tar.gz 1001582 SHA256 c0f860eee47c86e0aeb462fd0bdfd70e3975297e0b8b178e0e03a95e1f6c9bc4 SHA512 a9f5c047b39efb2d11b55ee9913662ca402ac6837b3ad2d278ecfbd1caf32ed4546f169e3e92503d57bf3b62ccf89cd062da1c7ea3638aae98e868d2766363c3 WHIRLPOOL 36edbdf8be7c3793a89918a3c43d74e75a6281a37c394f7d2f20506130a76aab04a3beddba01bf7f0e9b6901c7e834ca014c31c913c0ea846d3f6be9c93599d2
-EBUILD Macaulay2-1.7_pre.ebuild 3919 BLAKE2B 2725509e090173319aeb5cb99b86a2f8d59043aa2a91105042a9b6a1708975e6072b67ef3828a4d15694472f0166a05f0560073f3f1282048a48b2e69fe7c5b0 SHA512 14c8b36de0533f5779441adbe7ea993fd0fb1451f8482acb8f411fe0ba60f094d7cd5a5fabbacd570715bf6333baa1a8076d4f279d22983ccf182049d732176b
-EBUILD Macaulay2-1.8.2.1-r1.ebuild 3278 BLAKE2B f8003c3237419522cac131c72b7f59f2d7dcea73f751dddfde3486ca514108f831bd642c8c29cf36c8bc1c3761ffa9f4cf09d024205f9bedc016938760f37e7d SHA512 92d1d78fe0f63c11da1d6f3eab8307fb299b094bd54ff9afb12a8059e899a378dbbca6a911be224bb7de1bad9d2c5a29962398b79484c6b653df2467aaaefff2
+EBUILD Macaulay2-1.8.2.1-r1.ebuild 3279 BLAKE2B 5653e6a759199ccf422d4142ff55fbc6caa33c7e2500070573f2c11298a12be361b1e11a3d1167ff8ecc1ba1cefc811fa6c4ac61dd3030156c788a8c6f1724af SHA512 ff3476345a0786ac0754de306c273650499f9f7a6264b199ffebd339988e07b33abf4583ee2b96a73c0f3c3c3f731957af760d84f883c32cad61ccd6783a9960
MISC metadata.xml 527 BLAKE2B 8aac8a049fbb72e0ee7ee5cd71204857d86f00aa97c892f84b771628f1511e5124de7769006efb98e29e4644e9bcdf5a35c17eda63ca3d7c58a04e23cba19ab1 SHA512 7ca19042c8405096453426ec3582c3d342ff9a37ec520372f11ffd4e00a78ef018cc49d3f851e6dff2a000314f0eb6de0a4640d37edcb19ff2ad65196aaa03a1
diff --git a/sci-mathematics/Macaulay2/files/1.6-lapack.patch b/sci-mathematics/Macaulay2/files/1.6-lapack.patch
deleted file mode 100644
index e9a434eeb28e..000000000000
--- a/sci-mathematics/Macaulay2/files/1.6-lapack.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- configure.ac 2012-10-24 09:29:55.240498786 -0700
-+++ configure.ac.2 2012-10-30 15:07:27.172846300 -0700
-@@ -1285,46 +1285,7 @@
- done
- test $BUILD_factory = yes && BUILTLIBS="$SINGULARLIBS $BUILTLIBS"
-
--# we need to do the fortran library testing last, in case AC_SEARCH_LIBS adds
--# one of them to $LIBS, making it impossible to check for the presence of C or
--# C++ libraries. (I'm not sure why putting -llapack on the gcc command line
--# needlessly causes the library to be linked against.)
--FORTRANUSED=no
--if test "$LAPACK" = yes
--then AC_MSG_CHECKING([whether the vecLib framework is available])
-- SAVELIBS=$LIBS LIBS="-framework vecLib $LIBS"
-- AC_LANG(C)
-- AC_LINK_IFELSE(
-- [AC_LANG_PROGRAM(,[sgemv_();dgetrf_();])],
-- [
-- AC_MSG_RESULT(yes)
-- ],
-- [
-- AC_MSG_RESULT(no)
-- LIBS=$SAVELIBS
-- FORTRANUSED=yes
-- if test $BUILD_lapack = no
-- then AC_LANG(Fortran)
-- if test "$FC" = ""
-- then AC_MSG_ERROR(no fortran compiler found)
-- else AC_MSG_NOTICE(using fortran compiler $FC)
-- fi
-- AC_SEARCH_LIBS(sgemv,blas f77blas,,BUILD_lapack=yes)
-- AC_SEARCH_LIBS(dgetrf,lapack,,BUILD_lapack=yes)
-- fi
-- ])
--fi
--test $BUILD_lapack = yes && BUILTLIBS="-llapack -lblas $BUILTLIBS"
--
--if test $BUILD_lapack = yes
--then # test whether the fortran compiler can handle lapack, which, starting with
-- # version 3.2, requires fortran 90, not fortran 77
-- AC_LANG(Fortran)
-- AC_MSG_CHECKING([whether the fortran compiler is modern enough for lapack])
-- AC_COMPILE_IFELSE([instrinsic maxloc],
-- AC_MSG_ERROR(the fortran compiler ($FC) does not support the Fortran 90 language required for compiling lapack),
-- AC_MSG_RESULT(yes))
--fi
-+BUILTLIBS="$(${PKG_CONFIG} --libs lapack) $BUILTLIBS"
-
- if test $BUILD_memtailor = yes
- then BUILTLIBS="-lmemtailor $BUILTLIBS"