summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-03 23:49:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-03 23:49:50 +0100
commitc410d7a91a496a4fbbca686c80f7446305222d55 (patch)
tree8ba974498cd1061dd4e883a34bd5e9be93a95214 /sci-libs
parentc99c2410831577bef101e22948e954f85f56cba1 (diff)
gentoo auto-resync : 03:10:2023 - 23:49:49
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin44958 -> 44958 bytes
-rw-r--r--sci-libs/volk/Manifest1
-rw-r--r--sci-libs/volk/volk-9999.ebuild58
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index 2bcada3779d4..7eb1394e897d 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/volk/Manifest b/sci-libs/volk/Manifest
index ab44c4a1f527..815218e2479f 100644
--- a/sci-libs/volk/Manifest
+++ b/sci-libs/volk/Manifest
@@ -1,3 +1,4 @@
DIST volk-3.0.0.tar.xz 394044 BLAKE2B 04e832916375610571387db521348df2a37f5460500c4bd6d223dd6af9c0a207f3b22c599fccbf9bd51b8a87ed90cb5239512c19fc6ddd02320b7aa27c3be588 SHA512 5d1ff90f28ec6ef2d21370d74025139ccc9872e5a477b271ffe6662725b7705203715ea4ffc430554ec2fec56e8d9b40a945e75186761995d3075218e1f16313
EBUILD volk-3.0.0-r1.ebuild 1403 BLAKE2B c8db65638b1b66110b995533538de8cc8084355a5653bfacd0e077004b8dbe80400ecccc13a786f883b1c67f397b54db73b55efb54b698064d9b49f92be5acc7 SHA512 a504c1cfe9b6635f4434dbce84704b6829a342f8940b6a6c7852e615fefd3660dae8a01e8df4ba5d4252903071ab113145a293540d4c2d96932a841ffdf690f0
+EBUILD volk-9999.ebuild 1292 BLAKE2B ebbd8ddc6c8fdee7047fe680220ed9d80a18f176d81504f6bd6e1953af78d3d30721c7c4fb420f6d432ab1a6e620b28f2182b4ca01a1d1d75ed095ab0400b1db SHA512 d9816eed7b44cca190fa76edfa9637435766731a7f368ac39ac42c2ea98b317c059261e4f3201098dececb745a5f2e3d30cd8b00817ebc5b5ff744de627cd720
MISC metadata.xml 326 BLAKE2B add10950a24964807f5b5c4696f3852da2c19337e5db075bc1e2f9ba597812ac2b8e975b1747bf7a6a0e57420a9ea70f721d117f452c7971bb9a47765274938d SHA512 a5ce5f748eb162e852281a9a043c1bec629448da7f2f0a211f81c6671dbc10677aab06446fe9e1cd4105049ef95acbd03276d53472fbf73a8c3d608ea649787a
diff --git a/sci-libs/volk/volk-9999.ebuild b/sci-libs/volk/volk-9999.ebuild
new file mode 100644
index 000000000000..f86ccd6d99f6
--- /dev/null
+++ b/sci-libs/volk/volk-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+#https://github.com/gnuradio/volk/issues/383
+CMAKE_BUILD_TYPE="None"
+inherit cmake python-single-r1
+
+DESCRIPTION="vector optimized library of kernels"
+HOMEPAGE="http://libvolk.org"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gnuradio/volk.git"
+else
+ SRC_URI="https://github.com/gnuradio/volk/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="orc test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}
+ orc? ( dev-lang/orc )"
+DEPEND="${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mako[${PYTHON_USEDEP}]')"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ORC=$(usex orc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DENABLE_TESTING="$(usex test)"
+ -DENABLE_PROFILING=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ # Remove stray python files generated by the build system
+ find "${ED}" -name '*.pyc' -exec rm -f {} \; || die
+ find "${ED}" -name '*.pyo' -exec rm -f {} \; || die
+ python_optimize
+}
+
+src_test() {
+ local myctestargs=(
+ -E "(check_lgpl)"
+ )
+ cmake_src_test
+}