summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-22 07:00:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-22 07:00:36 +0000
commit267b3b848468a603048b181330ee73cf0bd99c44 (patch)
treed48682864ec3b9a40741db3604455fbc723465b2 /sci-libs
parent58d5ec1c1e98326577fa902f6c9c568639b18d12 (diff)
gentoo auto-resync : 22:03:2024 - 07:00:36
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin45128 -> 45134 bytes
-rw-r--r--sci-libs/cddlib/Manifest3
-rw-r--r--sci-libs/cddlib/cddlib-094m-r1.ebuild9
-rw-r--r--sci-libs/cddlib/cddlib-094m-r2.ebuild62
-rw-r--r--sci-libs/libmuscle/Manifest2
-rw-r--r--sci-libs/libmuscle/libmuscle-3.7-r4.ebuild (renamed from sci-libs/libmuscle/libmuscle-3.7-r3.ebuild)15
6 files changed, 84 insertions, 7 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index 9caf4809d415..fef699b9b0d6 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/cddlib/Manifest b/sci-libs/cddlib/Manifest
index 53008be2f539..4f5ceda557b1 100644
--- a/sci-libs/cddlib/Manifest
+++ b/sci-libs/cddlib/Manifest
@@ -1,3 +1,4 @@
DIST cddlib-0.94m.tar.gz 1351298 BLAKE2B 0e1931ba94771f0dcae0ee10b003940ca331839eb8ce001ab02c4f1b382dde74d7dfcf74f4c62e1ae7214a3139547c09f56ef0cba5df74fc03a63ab741b64690 SHA512 50997bda38c36990456345881dc1eac65b1880aa510ea3812ae46a122ba7696bf3577f2b6976ff16811ee00f0a920c8ed6f1e7de0a4060bfaa96def11bab816e
-EBUILD cddlib-094m-r1.ebuild 1447 BLAKE2B 4a295e634092531a352245220fd3839ef589bd7e3050df1f401ee1099c24e069507053ca129ec6913ee41ff4c110945ed01136180f00be3a17f256b493823262 SHA512 3a9dd72a02e9f04f0ab86c476bfa0370889531e6b9067a062e0c30b4b1d8cee36901169e96a6014473e77cb8ffb0536700c42ac7a8c55fd2e9d9791620ab5cfb
+EBUILD cddlib-094m-r1.ebuild 1505 BLAKE2B 0a6b6cdd3a2989caca5e7fcb0c55c98d3ad1adaedc9dd97a1d29c58c86c1d25a1436e12f6a3415557ad99d51f53049f520b11662c660154288046556ba4a68f4 SHA512 2f4d7950f1b1cbc85f127e7dedad907a2c8e0a0123b1874ad3c7c832fe5fe5c1974f5e8ca7bd54812763da8c9f0e73e761131a04a5d0ad2f5009426f490f3740
+EBUILD cddlib-094m-r2.ebuild 1506 BLAKE2B 0bcd2486e64b7dac0393a2c3c6064003742ee661d092342a3bc94078481c2f421b1ff1da607c9e0d7a16b5f1ae4fff3e8c994b4ba6ac3d82deda4120ceefd116 SHA512 a2b1749e23ff3ec2158a8966c778582611a27c4f0598248517109d9420a694932e7db6256c32d9afc3ebe4e50c3bfd2828a1b38d09a16917bcede992c967468a
MISC metadata.xml 1848 BLAKE2B 98d72e3809807ac701b575e31068012b568893cc4db0cb8b12c0a0ec6c83862e3e132981192026a279c1bf516fda829e20fb9e314ddd3fa0bcd5613f2e074f33 SHA512 d4b7eccde619f6be50621dba566a186b46c62537dfb26c3d34157ddad7179040ea9ddfaa7b63e363053c935d101581bdeb3a4350db955665d4d163b322e43367
diff --git a/sci-libs/cddlib/cddlib-094m-r1.ebuild b/sci-libs/cddlib/cddlib-094m-r1.ebuild
index 5cb23824058f..4a38f957054c 100644
--- a/sci-libs/cddlib/cddlib-094m-r1.ebuild
+++ b/sci-libs/cddlib/cddlib-094m-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit libtool
+
# This can't work forever; but for now, it's better than hard-coding the
# correct version string.
MY_PV="${PV:0:1}.${PV:1}"
@@ -23,6 +25,11 @@ RDEPEND="dev-libs/gmp:0="
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf $(use_enable static-libs static)
}
diff --git a/sci-libs/cddlib/cddlib-094m-r2.ebuild b/sci-libs/cddlib/cddlib-094m-r2.ebuild
new file mode 100644
index 000000000000..521abc9a7448
--- /dev/null
+++ b/sci-libs/cddlib/cddlib-094m-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool
+
+# This can't work forever; but for now, it's better than hard-coding the
+# correct version string.
+MY_PV="${PV:0:1}.${PV:1}"
+QA_PKGCONFIG_VERSION="${MY_PV}"
+
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="C library implementing the Double Description Method"
+HOMEPAGE="https://www.inf.ethz.ch/personal/fukudak/cdd_home/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs tools"
+
+DEPEND="dev-libs/gmp:0"
+RDEPEND="dev-libs/gmp:0="
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use tools; then
+ rm "${ED}"/usr/bin/* || die
+ fi
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+
+ # Nobody wants the dvi/ps manual...
+ rm "${ED}/usr/share/doc/${PF}"/cddlibman.{dvi,ps} || die
+
+ # since the PDF manual is installed by default.
+ if ! use doc; then
+ rm "${ED}/usr/share/doc/${PF}"/cddlibman.pdf || die
+ fi
+
+ # The docs and examples are *both* installed by default, so we
+ # have to remove the examples if the user doesn't want them.
+ docompress -x "/usr/share/doc/${PF}"/examples{,-ext,-ine,-ine3d}
+ if ! use examples; then
+ rm -r "${ED}/usr/share/doc/${PF}"/examples{,-ext,-ine,-ine3d} || die
+ fi
+}
diff --git a/sci-libs/libmuscle/Manifest b/sci-libs/libmuscle/Manifest
index e7168d983c70..2620d7eead6d 100644
--- a/sci-libs/libmuscle/Manifest
+++ b/sci-libs/libmuscle/Manifest
@@ -1,5 +1,5 @@
AUX 3.7-bufferoverflow.patch 447 BLAKE2B 264ed3242328a3eedd9fa8957c13b5562f2d7514951b5383357278aca325e81fe2fd25bf77938f676df303d67ac95475cac83a62af64d13fd3eda780d454477f SHA512 09dd1fca3e75eb753a820c2f2957422c9433698af5bcbc572d48e437052d76522bac0b68923d296346d654f5e9130c15839180c4a635d9247e1ddf51993bcce6
AUX libmuscle-3.7-fix-build-system.patch 918 BLAKE2B 9e68d55b206a8fb7c0abdf1b820d5e4fb698cf17afee3188848333ebdd362048d7243c864283a8c0efb4794bc3c7e97f48fbbbdfbc6baf954be27d56d4b60f9c SHA512 bb1590e8a9980de3a92fba16ce3e45a04a1cdf2f2a7fbbaedeba48f3d08f398e03bb6be7a9c9c0ba39a8772bc24d844480e9b57dce0f391d92b2f595e09677e0
DIST libmuscle-3.7-r1.tar.bz2 458852 BLAKE2B 7f3fc693f9e1ca47f16020055b49b5130e5b3ee69a51b390e335bef67f643001470ad06ffbed7abafbd0beb6a97fe7c9b84ea3d908146ec74f1d0a6ac409777f SHA512 3031070dcd888c327b023eeb225a291bf36ec0c6fa8046fb1d945929305692bcdb3bc9623b02dfd753e086d3524bb7f10b9b011f663e38c71b17f6f516c0ac62
-EBUILD libmuscle-3.7-r3.ebuild 724 BLAKE2B 0093ea410e0fb0ce8ec8047261c1875f9d21242ace084a03a99863dac7606baf5fe653ef2be22ca6fd354dd404d842e2146738c5d99b47ba89d20c2fab9b4f38 SHA512 8bbb27479ed46dc3b9d11422372404bd873d3a3ea6c2d71f66fb7dc58aabbff843a899cc9a293419df9d65b421dfdd1b257e9b16b0789577f1af4959543f0ee3
+EBUILD libmuscle-3.7-r4.ebuild 932 BLAKE2B 720ac56752e3da8b6c4469320da1a17ca45b19fd14fb5d2ae7dc5ba31e5651f2bb1e3ae67bd7c464a5355b775009690d0a5a0e66ce1dd8362ac13b4919227125 SHA512 4ca8a5a0192c2bfdf61f2cac2abf68cb77585d530dc69d7a3e05e3fddbb149be02e2a9ca0b78df132e8385778f581f804f3906874920f95485f62445e0a213e3
MISC metadata.xml 262 BLAKE2B adaacf2ac22ce09f8b1b68f538773c1e2101156181ff302eca2ce1280ee5d45db4eb302a8eee1bbead5e55942443dd16ef924cfbfdc95a1658dc6a9f460468a2 SHA512 ac924b6b530d96645f173d40f7a2bf0e3abbf49048ebf7fadcea3dd553cd25504f0e68a103395de1fb59a2e5e11497dcead601be01cc6f0295ccbc4155f67e3f
diff --git a/sci-libs/libmuscle/libmuscle-3.7-r3.ebuild b/sci-libs/libmuscle/libmuscle-3.7-r4.ebuild
index 5711d8d45991..1a00a894d11e 100644
--- a/sci-libs/libmuscle/libmuscle-3.7-r3.ebuild
+++ b/sci-libs/libmuscle/libmuscle-3.7-r4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Library for sci-biology/mauve"
HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
@@ -15,8 +15,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc static-libs"
RDEPEND="!sci-biology/muscle"
-DEPEND="${RDEPEND}
- doc? ( app-text/doxygen )"
+BDEPEND="doc? ( app-text/doxygen )"
PATCHES=(
"${FILESDIR}"/${PV}-bufferoverflow.patch
@@ -29,6 +28,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862897
+ # Upstream website doesn't load. Nowhere to report bugs to.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
econf $(use_enable static-libs static)
}