summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-17 01:13:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-17 01:13:38 +0000
commit0e82736d0df44565875b055019ded1be0ac5c319 (patch)
treebd9daea4309088c78f6b358305ab15849d97d159 /sci-libs
parent79be8f00e2aa293669b8e22e1ef02d2d5c5f9e25 (diff)
gentoo auto-resync : 17:01:2023 - 01:13:38
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin44223 -> 44229 bytes
-rw-r--r--sci-libs/brial/Manifest2
-rw-r--r--sci-libs/brial/brial-1.2.12.ebuild36
-rw-r--r--sci-libs/fplll/Manifest2
-rw-r--r--sci-libs/fplll/fplll-5.4.4.ebuild29
5 files changed, 69 insertions, 0 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index 99f155e73c68..4d9341b3e7e8 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/brial/Manifest b/sci-libs/brial/Manifest
index 3c0f9ae66721..2044d39c7abb 100644
--- a/sci-libs/brial/Manifest
+++ b/sci-libs/brial/Manifest
@@ -1,3 +1,5 @@
DIST brial-1.2.11.tar.bz2 1260892 BLAKE2B 910f4ffd728235c8b18deb0d36c76778ce2c392644b7eaba06a9c00a832b4ccb0c2cd69f4d9ab9770e060b54491bd6b613e4e1324a32f57d7c32f200fb0a900d SHA512 00532b6361c709fce44940bfd22563046cfcbc06d41282a01a26f9bcb25fa86df1406685d7ba4b1ebbb08cd7fa8b9811c81eccf78e72ea96960ef7a059c2e926
+DIST brial-1.2.12.tar.bz2 1259569 BLAKE2B bf9415b2980d76d00239eceea113d6dbb916f5dcec3bdecb05db0ad1988761e4d25ab9a0419c68a3b2501f1f9dc6e2d31418aea7c727cfd01f4ae76eea8f81e2 SHA512 c44902f0f935d614b8c2d437d6c895f650ff4b77501ac3ba035e21671719f4080c88a173819f8db8e8b7dda121736146d8388b70ad7cda75207a1b22b93f5af6
EBUILD brial-1.2.11.ebuild 910 BLAKE2B 450ef8351b4ed6686d58ea3f336fc80a5aacceb0e26a96f211738e57c575be32b428d000f7b4a0b0f97d62d0655f9eacd777600af07cdca8ea618e218cb2e29a SHA512 a183e49c9564809b96535ebf82ecb5e725a75ef3149f4e8504860a06aa6fabc76c655a11fb765a65576cd4ce4988597d4562aabda37e76a3c265b6c353343140
+EBUILD brial-1.2.12.ebuild 912 BLAKE2B 006bf52542180b3fe8330647934350f04756eac488cdf450ea2465bbe66117d222d8be47510986edb0fbf41b90bb260ad5ae0ea1f30476d40da31b3d3236706e SHA512 ce280ef084f837f720123ba345fb030e155339535fe41df92c0354fbe73fcc6c00bee3ed585e366c94e9eafe417a3ed9b17b1bf279fef7aecf2974a6d203767d
MISC metadata.xml 1077 BLAKE2B 516f3390d40d27d4d1934be2eea344e888112ae8912985134bc288fe4d9414f49100874ddf94f7b0d517e60b7a37801464a6f64108df0465a015e6e9f3c3702e SHA512 284c49e862464bf2d825598a9ef6aa6dbf40c6f42f02f1dcb53f7d3baf8c728771dec129a63fcadb711c40ff623e5c4036cfdc54afc4dbaf07c73b75329aefe0
diff --git a/sci-libs/brial/brial-1.2.12.ebuild b/sci-libs/brial/brial-1.2.12.ebuild
new file mode 100644
index 000000000000..31821f7a6cde
--- /dev/null
+++ b/sci-libs/brial/brial-1.2.12.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A C++ library for polynomials over boolean rings"
+HOMEPAGE="https://github.com/BRiAl/BRiAl"
+SRC_URI="https://github.com/BRiAl/BRiAl/releases/download/${PV}/${P}.tar.bz2"
+
+# The top-level license is GPL2+, but cudd/LICENSE is BSD.
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="png"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/boost
+ sci-libs/m4ri[png=]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ tc-export PKG_CONFIG
+
+ # with-boost-libdir added to deal with some rather quirky setups
+ # see https://github.com/cschwan/sage-on-gentoo/issues/551
+ econf \
+ --with-boost="${ESYSROOT}"/usr \
+ --with-boost-libdir="${ESYSROOT}"/usr/$(get_libdir)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/fplll/Manifest b/sci-libs/fplll/Manifest
index c976b079cc54..4521e4d6049a 100644
--- a/sci-libs/fplll/Manifest
+++ b/sci-libs/fplll/Manifest
@@ -1,4 +1,6 @@
AUX fplll-5.4.2-with-qd-fix.patch 942 BLAKE2B 3335262a47db7cc8fe48d79f2638882a8522ea026f55bbcd9b612457ef6186b84e673e0d9b0b9a022f4a3915dff830ab28ab47a5093fc3364fa4d4fc1317ef8f SHA512 4fcfb3aea3fe72d8072996c2bc6e5f626b4972448871578a29119cd10325d0451186d410f6732d58f96eb18ae040ed8410213228b63aa3012dba63a1916e68bd
DIST fplll-5.4.2.tar.gz 2618377 BLAKE2B e730c8646b9afb68515a23e533ea8ef833439d69f2130157bd6e38b1efab9116817535c261721c98b23410185271ffc323c687630e3ba262adb97fa5f69be787 SHA512 45324d89d0efeb269c1d1400332a51432e5d09f7bf0a6d651650e0941bb718493cbb66d65056b98691691236eaf348b2cae686ee06761f64380df98b6206c004
+DIST fplll-5.4.4.tar.gz 2630101 BLAKE2B b990c9346acd2c506b4697f27ff21d8453bb97473b2e988beb2ab9da34b3edd8a64d7558bca5f66a888fb4397c1e5340cf50f543ec580f0ec6980bc8c73a9390 SHA512 32a6515a3ab2677739a60a4ef0938e4284b5d3119a396104a7af22a6291ef669b42a4fb6e59f5c6daf97ff2402e7d035ea84fd1c76bfe7c0e17402bd03ae7166
EBUILD fplll-5.4.2.ebuild 766 BLAKE2B d7862862614674ee233c8e9dc336d85098699c6743e8b1e0b8363bb11130b2e246972301373cb50dec1c3b0b373bb02fec90616c2619e9572e35a7a1e83d0668 SHA512 a115045f6e5ceeb501714775db7a08b15928096100b23b89a597eef41cc61768a9add4dfd53b16974794ab7cd47a5296824dc02a5341a55115f478b827a4e127
+EBUILD fplll-5.4.4.ebuild 609 BLAKE2B 026d1aca2546eb033bcbd934d25eee8b7ae42798febd3c8fdd46243675bca07310d1b4f5840322fefb921f1e1f699b8d9b939da6c61606e3a07a09c24b8ece02 SHA512 2f83e6daf53eb8ec3e9a34d203fc0ea86c4fe9154ba381a6087a9cc0e1ff4602f851f1c3ed0bf00509adc0d3a56556009a88e1f464721757eee189402a8efc6e
MISC metadata.xml 858 BLAKE2B e27b47f6a8d0bb3c17eb023c24f95472c5f791e8a9bf86c1805d1c832b0973a665fe2231f82a289c37afd5318deb89717029ae6694005ade8e112a2769a56170 SHA512 49b6fd4968670fb0da92a883b81420e4739a893a6866ae500106181df5182324e616ccee8e0f290a7cda20f3f4d850fbf9a9462d03f0057da9ced4ba1d835ba7
diff --git a/sci-libs/fplll/fplll-5.4.4.ebuild b/sci-libs/fplll/fplll-5.4.4.ebuild
new file mode 100644
index 000000000000..d8ad2144d60b
--- /dev/null
+++ b/sci-libs/fplll/fplll-5.4.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="https://github.com/fplll/fplll"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8"
+KEYWORDS="~amd64 ~x86"
+IUSE="qd"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/gmp:0
+ dev-libs/mpfr:0
+ qd? ( sci-libs/qd )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with qd)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}