summaryrefslogtreecommitdiff
path: root/sci-libs/xylib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
commitfaddeff65d652bda3291eba255955adb17f1aa19 (patch)
tree4352e6d85ce48c7c8d96159fad4d3dd90602a70a /sci-libs/xylib
parent0e7b1da874d923b9f006e0000023f5fa528140a8 (diff)
gentoo auto-resync : 24:11:2023 - 16:33:11
Diffstat (limited to 'sci-libs/xylib')
-rw-r--r--sci-libs/xylib/Manifest1
-rw-r--r--sci-libs/xylib/xylib-1.6-r1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/xylib/Manifest b/sci-libs/xylib/Manifest
index 5a43aff088e5..af332ca3875a 100644
--- a/sci-libs/xylib/Manifest
+++ b/sci-libs/xylib/Manifest
@@ -1,3 +1,4 @@
DIST xylib-1.6.tar.bz2 370765 BLAKE2B 76eb968f06a6a015ed7a29a493d888642767cda103733498b8706c973498aa4ac8576716b06f6eae8d95a1f625e9cd91ab02cfd53146d976e32fc9295f3c502f SHA512 9861cbf03f8b921a93a2d32a529ff94d77723e2510cd61096b4b85f91af4be6330ed82e8da94bc45dbca7f9814077360d1dae204315b28c2b6d85e3d2c7f6696
+EBUILD xylib-1.6-r1.ebuild 889 BLAKE2B f6c61f229c9468a8d80f52191ba7557c5c0073e30e375f8354f8e4f75db5ae46dc8ae4d3da0f69d869f5252dca15bc4c397402bfe2467917d5271e16f274bbe3 SHA512 bb95791cb9944f9d72f30af29dd3be046311ca1f0213006088b16b5e02e65c8a6eb946dad871740117af81a6e41a1df35b2d99bc92342f293fad087c063e7a5a
EBUILD xylib-1.6.ebuild 807 BLAKE2B e15510175a2dd0013cadda8239039b4ac9a791265142f47f4be44b6538c0499256b5101ea96563cc1c2458a1ca3548b808909f213233bdac1c82df1f9618c574 SHA512 4c09b69be3205c1924a8cef18f4a5ca8fe5cfd73c2e83eb5d795f1c1b36117b2a50e5de8d64de73ccfdc31f7bb544906d645bc816b3669637432725c0d738950
MISC metadata.xml 563 BLAKE2B 6f65b58cfbbe90662df9c13d052007bba7a4d194ce591f114d19e097843cfc74385a60267a589c532c8a321fbddf2f7acd74225b8597f7c25b963c3d3f8a6772 SHA512 dc4651cc181fac0f11b83dbd8f6633354ac7c6686a1c8d5443f0c36f7eb16f7510ad38fd22ac82cc2d80f3c1ab0d66709a182ba2a77141f199535effbb98eaa5
diff --git a/sci-libs/xylib/xylib-1.6-r1.ebuild b/sci-libs/xylib/xylib-1.6-r1.ebuild
new file mode 100644
index 000000000000..1428662cc66d
--- /dev/null
+++ b/sci-libs/xylib/xylib-1.6-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER=3.2-gtk3
+
+inherit desktop wxwidgets
+
+DESCRIPTION="Experimental x-y data reading library"
+HOMEPAGE="https://github.com/wojdyr/xylib"
+SRC_URI="https://github.com/wojdyr/xylib/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 gui zlib"
+
+RDEPEND="
+ bzip2? ( app-arch/bzip2 )
+ gui? ( x11-libs/wxGTK:${WX_GTK_VER} )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+
+src_configure() {
+ use gui && setup-wxwidgets
+
+ econf \
+ --disable-static \
+ $(use_with bzip2 bzlib) \
+ $(use_with gui) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ newicon gui/xyconvert48.xpm xyconvert.xpm
+ make_desktop_entry xyconvert xyConvert xyconvert.xpm
+}