summaryrefslogtreecommitdiff
path: root/sci-libs/xdrfile/xdrfile-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/xdrfile/xdrfile-1.1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/xdrfile/xdrfile-1.1.1.ebuild')
-rw-r--r--sci-libs/xdrfile/xdrfile-1.1.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-libs/xdrfile/xdrfile-1.1.1.ebuild b/sci-libs/xdrfile/xdrfile-1.1.1.ebuild
new file mode 100644
index 000000000000..8994b56ef506
--- /dev/null
+++ b/sci-libs/xdrfile/xdrfile-1.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+FORTRAN_NEEDED="fortran"
+
+inherit autotools-multilib fortran-2
+
+DESCRIPTION="Library to read gromacs trajectory and topology files"
+HOMEPAGE="http://www.gromacs.org/Developer_Zone/Programming_Guide/XTC_Library"
+SRC_URI="ftp://ftp.gromacs.org/pub/contrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="fortran static-libs"
+
+src_configure() {
+ local myeconfargs=( $(use_enable fortran) )
+
+ autotools-multilib_src_configure
+}