summaryrefslogtreecommitdiff
path: root/sci-libs/vtk/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sci-libs/vtk/files
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sci-libs/vtk/files')
-rw-r--r--sci-libs/vtk/files/vtk-9.1.0-adjust-to-find-binaries.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-libs/vtk/files/vtk-9.1.0-adjust-to-find-binaries.patch b/sci-libs/vtk/files/vtk-9.1.0-adjust-to-find-binaries.patch
new file mode 100644
index 000000000000..10d6d251ebf3
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-9.1.0-adjust-to-find-binaries.patch
@@ -0,0 +1,25 @@
+From e59b8ff7b83cd6a58c226cb4f5d9661bcb29002b Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Thu, 31 Mar 2022 08:05:17 +0200
+Subject: [PATCH] adjust to find binaries
+
+Add compatibility for qt-5.15.3 with no qtchooser installed. QtCore exports
+Qt5::{qmake,moc,rcc} which we use to get the path for binaries.
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/GUISupport/QtQuick/qml/CMakeLists.txt
++++ b/GUISupport/QtQuick/qml/CMakeLists.txt
+@@ -60,8 +60,8 @@ file(GENERATE
+ # Generate the qmltypes file for the VTK QML plugin
+
+ # First, find the qmlplugindump executable
+-get_target_property(qt_core_location "Qt${vtk_qt_major_version}::Core" LOCATION)
+-get_filename_component(qt_bin_dir "${qt_core_location}" PATH)
++get_target_property(qt_qmake_location "Qt${vtk_qt_major_version}::qmake" LOCATION)
++get_filename_component(qt_bin_dir "${qt_qmake_location}" PATH)
+ if (APPLE)
+ get_filename_component(qt_bin_dir "${qt_bin_dir}" PATH)
+ endif ()
+--
+2.35.1
+