summaryrefslogtreecommitdiff
path: root/sci-libs/votca-tools/votca-tools-1.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sci-libs/votca-tools/votca-tools-1.5.1.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sci-libs/votca-tools/votca-tools-1.5.1.ebuild')
-rw-r--r--sci-libs/votca-tools/votca-tools-1.5.1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/sci-libs/votca-tools/votca-tools-1.5.1.ebuild b/sci-libs/votca-tools/votca-tools-1.5.1.ebuild
deleted file mode 100644
index 7c07b1f80ccd..000000000000
--- a/sci-libs/votca-tools/votca-tools-1.5.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-CMAKE_MAKEFILE_GENERATOR="ninja"
-
-inherit cmake-utils multilib
-
-if [ "${PV}" != "9999" ]; then
- SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux"
- S="${WORKDIR}/${P#votca-}"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN/-//}.git"
-fi
-
-DESCRIPTION="Votca tools library"
-HOMEPAGE="http://www.votca.org"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="doc +fftw sqlite"
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/expat
- >=dev-cpp/eigen-3.3
- fftw? ( sci-libs/fftw:3.0 )
- sqlite? ( dev-db/sqlite:3 )"
-
-DEPEND="${RDEPEND}
- doc? ( >=app-doc/doxygen-1.7.6.1[dot] )
- >=app-text/txt2tags-2.5
- virtual/pkgconfig"
-
-DOCS=( NOTICE )
-
-src_configure() {
- mycmakeargs=(
- -DWITH_FFTW=$(usex fftw)
- -DWITH_SQLITE3=$(usex sqlite)
- -DWITH_RC_FILES=OFF
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- if use doc; then
- cd "${CMAKE_BUILD_DIR}"
- cmake-utils_src_make html
- dodoc -r share/doc/html
- fi
-}