summaryrefslogtreecommitdiff
path: root/sci-libs/voro++
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /sci-libs/voro++
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'sci-libs/voro++')
-rw-r--r--sci-libs/voro++/Manifest4
-rw-r--r--sci-libs/voro++/files/voro++-0.4.6-cmake.patch60
-rw-r--r--sci-libs/voro++/voro++-0.4.6-r1.ebuild15
3 files changed, 17 insertions, 62 deletions
diff --git a/sci-libs/voro++/Manifest b/sci-libs/voro++/Manifest
index 32803d63d68e..25e2b363a940 100644
--- a/sci-libs/voro++/Manifest
+++ b/sci-libs/voro++/Manifest
@@ -1,4 +1,4 @@
-AUX voro++-0.4.6-cmake.patch 5811 BLAKE2B 2d0e54fdbc4b3603624365a08c2b9cf76271a403308ade16c36b74c01b3cb7273d47fd25ff9d6eccb3ed292ac87d9256e827276dd4034064167b335856eb48e1 SHA512 6c8d8168432a5cad2713e8fea7e990004f9ff99a5114b0687e7e277cc09009d2545e47ab3389332f3ae342ae71ecae2b71e1cbe85dc5ed20fff29200b95912c1
+AUX voro++-0.4.6-cmake.patch 4197 BLAKE2B 294957cc8879e996af0a7cc205eabd501114fdec41380620b8162f1a63a4c88c9e042ac832b33c1ee7e3805321ae1396f3aa93cb2cbf0fb44cdf70878201aa58 SHA512 87c92d3e899242467c2df9a08f863d34255b0e14e080a07d9eaecbf111bb0ca181f68bde899373c8e6bbf1d2d730a547d880d14d2bb988b66a741ebd0f76c09a
DIST voro++-0.4.6.tar.gz 809124 BLAKE2B 0b12f68fe2400d850353171a79aa41dd0a7780dd38d8b7d5fcda6621ba43e5bad60d72a1dd24c3ef9e30d4b63c0be9467062ef33f27138a838f7a984dd3321a2 SHA512 aa8c73d7634bb4ec4c0a7d4d18c0df07511ef975338f2517e6f0ec65de56bac10397adccf1c0e13439d29d096b7cb9b4540d7cfc191a1662f15dc0c3c1ff77c1
-EBUILD voro++-0.4.6-r1.ebuild 475 BLAKE2B d8e6d237b29b78eeafd610ee1b4c627e83af9a3796d2110424d710ee241dcb636807f3db79e48aad30b8e074ad59fe3037af9518a8882e22f4199690fc953743 SHA512 4857de518ee5913523014fe0de4064a09713802d96fecf34a4e1313476f73f290fb6b67171a14daefab658bf702f0b4093f77da6eec4830892d9a720759301f8
+EBUILD voro++-0.4.6-r1.ebuild 373 BLAKE2B 12fe8c3fd2a466637d61549453581a302152d7d1a56c80befdf690edc6e4063e56ec2e042ba949b7a1273b62d96bb6c1316059c9336f6631e632f3725c82e681 SHA512 56e0a01a0303d69421e21fbfc8de58efe16b8cbbf7caa12873244070d552177782f62fb4c6ed15dc973897eab1bffd793f87ce6e9fc35ec502cb808abcc5f9c6
MISC metadata.xml 259 BLAKE2B dfc879984b6adce945d0e0a50f6ede2bca87147b9db99491359cdeccc2e74a20d56e14ae8903dbb80c94854f89bee539f14a4e3ce864204e277accf3f124a748 SHA512 19fb78cf4029c154954a40df40e28fc8d98a8b7e6b42f97259f664d44c29b284feffb9d073cadc7f90b5654a64b2466e186cb677d3a11830206f173eb9057706
diff --git a/sci-libs/voro++/files/voro++-0.4.6-cmake.patch b/sci-libs/voro++/files/voro++-0.4.6-cmake.patch
index c848748c5cf7..f8310097b76d 100644
--- a/sci-libs/voro++/files/voro++-0.4.6-cmake.patch
+++ b/sci-libs/voro++/files/voro++-0.4.6-cmake.patch
@@ -1,9 +1,9 @@
Index: CMakeLists.txt
===================================================================
---- a/CMakeLists.txt (revision 0)
-+++ b/CMakeLists.txt (working copy)
-@@ -0,0 +1,109 @@
-+cmake_minimum_required(VERSION 2.6)
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -0,0 +1,98 @@
++cmake_minimum_required(VERSION 2.8.12)
+
+project(voro++)
+
@@ -28,18 +28,9 @@ Index: CMakeLists.txt
+include(CheckCXXCompilerFlag)
+
+########################################################################
-+# User input options #
++# Standard install paths #
+########################################################################
-+option(BUILD_SHARED_LIBS "Build shared libs" ON)
-+if (NOT DEFINED LIB)
-+ set(LIB "lib")
-+endif(NOT DEFINED LIB)
-+if (NOT DEFINED MAN)
-+ set(MAN "share/man")
-+endif(NOT DEFINED MAN)
-+if (NOT DEFINED DATA)
-+ set(DATA "share/voro++")
-+endif(NOT DEFINED DATA)
++include(GNUInstallDirs)
+
+########################################################################
+#Find external packages
@@ -78,14 +69,14 @@ Index: CMakeLists.txt
+set_target_properties(voro++ PROPERTIES
+ LIBRARY_OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}/src"
+ SOVERSION ${SOVERSION})
-+install(TARGETS voro++ LIBRARY DESTINATION ${LIB} ARCHIVE DESTINATION ${LIB})
++install(TARGETS voro++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
+
+add_executable(cmd_line src/cmd_line.cc)
+target_link_libraries(cmd_line voro++)
+#cannot have two target with the same name
+set_target_properties(cmd_line PROPERTIES OUTPUT_NAME voro++
+ RUNTIME_OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}/src")
-+install(TARGETS cmd_line RUNTIME DESTINATION bin)
++install(TARGETS cmd_line RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+
+#for voto++.hh
+include_directories(${CMAKE_SOURCE_DIR}/src)
@@ -102,40 +93,11 @@ Index: CMakeLists.txt
+endforeach(SOURCE)
+
+file(GLOB_RECURSE VORO_HEADERS src/*.hh)
-+install(FILES ${VORO_HEADERS} DESTINATION include/voro++)
-+install(FILES ${CMAKE_SOURCE_DIR}/man/voro++.1 DESTINATION ${MAN}/man1)
++install(FILES ${VORO_HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/voro++)
++install(FILES ${CMAKE_SOURCE_DIR}/man/voro++.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
+
+if (DOXYGEN_FOUND)
-+ add_custom_target(help COMMAND ${DOXYGEN_EXECUTABLE} src/Doxyfile
++ add_custom_target(doxygen COMMAND ${DOXYGEN_EXECUTABLE} src/Doxyfile
+ COMMENT "Build doxygen documentation")
+endif (DOXYGEN_FOUND)
+
-+configure_file(${CMAKE_MODULE_PATH}/cmake_uninstall.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake IMMEDIATE @ONLY)
-+add_custom_target(uninstall COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake)
-Index: CMakeModules/cmake_uninstall.cmake.in
-===================================================================
---- a/CMakeModules/cmake_uninstall.cmake.in (revision 0)
-+++ b/CMakeModules/cmake_uninstall.cmake.in (working copy)
-@@ -0,0 +1,22 @@
-+IF(NOT EXISTS "@CMAKE_CURRENT_BINARY_DIR@/install_manifest.txt")
-+ MESSAGE(FATAL_ERROR "Cannot find install manifest: \"@CMAKE_CURRENT_BINARY_DIR@/install_manifest.txt\"")
-+ENDIF(NOT EXISTS "@CMAKE_CURRENT_BINARY_DIR@/install_manifest.txt")
-+
-+FILE(READ "@CMAKE_CURRENT_BINARY_DIR@/install_manifest.txt" files)
-+STRING(REGEX REPLACE "\n" ";" files "${files}")
-+FOREACH(file ${files})
-+ MESSAGE(STATUS "Uninstalling \"$ENV{DESTDIR}${file}\"")
-+ IF(EXISTS "$ENV{DESTDIR}${file}")
-+ EXEC_PROGRAM(
-+ "@CMAKE_COMMAND@" ARGS "-E remove \"$ENV{DESTDIR}${file}\""
-+ OUTPUT_VARIABLE rm_out
-+ RETURN_VALUE rm_retval
-+ )
-+ IF(NOT "${rm_retval}" STREQUAL 0)
-+ MESSAGE(FATAL_ERROR "Problem when removing \"$ENV{DESTDIR}${file}\"")
-+ ENDIF(NOT "${rm_retval}" STREQUAL 0)
-+ ELSE(EXISTS "$ENV{DESTDIR}${file}")
-+ MESSAGE(STATUS "File \"$ENV{DESTDIR}${file}\" does not exist.")
-+ ENDIF(EXISTS "$ENV{DESTDIR}${file}")
-+ENDFOREACH(file)
-+
diff --git a/sci-libs/voro++/voro++-0.4.6-r1.ebuild b/sci-libs/voro++/voro++-0.4.6-r1.ebuild
index b1fa72623758..a2ab69b03aa5 100644
--- a/sci-libs/voro++/voro++-0.4.6-r1.ebuild
+++ b/sci-libs/voro++/voro++-0.4.6-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
-DESCRIPTION="A 3D Voronoi cell software library"
+DESCRIPTION="3D Voronoi cell software library"
HOMEPAGE="http://math.lbl.gov/voro++/"
SRC_URI="http://math.lbl.gov/voro++/download/dir/${P}.tar.gz"
@@ -15,10 +15,3 @@ KEYWORDS="amd64 x86"
IUSE=""
PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
-
-src_configure() {
- local mycmakeargs=(
- -DLIB=$(get_libdir)
- )
- cmake-utils_src_configure
-}