summaryrefslogtreecommitdiff
path: root/sci-libs/volk/volk-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-18 08:07:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-18 08:07:22 +0000
commit88a7ab8599213acca9dd34eb21748ff54d7c190a (patch)
tree7b0906984ae3d3754da31f07f7c730f719d2f92a /sci-libs/volk/volk-3.1.0.ebuild
parent942c9977e0273ee6c6bd3f9822263aaeab1b69a5 (diff)
gentoo auto-resync : 18:01:2024 - 08:07:22
Diffstat (limited to 'sci-libs/volk/volk-3.1.0.ebuild')
-rw-r--r--sci-libs/volk/volk-3.1.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/volk/volk-3.1.0.ebuild b/sci-libs/volk/volk-3.1.0.ebuild
new file mode 100644
index 000000000000..0a400d90ff06
--- /dev/null
+++ b/sci-libs/volk/volk-3.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+#https://github.com/gnuradio/volk/issues/383
+CMAKE_BUILD_TYPE="None"
+inherit cmake python-single-r1
+
+DESCRIPTION="vector optimized library of kernels"
+HOMEPAGE="http://libvolk.org"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gnuradio/volk.git"
+else
+ SRC_URI="https://github.com/gnuradio/volk/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="orc test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}
+ orc? ( dev-lang/orc )"
+DEPEND="${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mako[${PYTHON_USEDEP}]')"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ORC=$(usex orc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DENABLE_TESTING="$(usex test)"
+ -DENABLE_PROFILING=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ # Remove stray python files generated by the build system
+ find "${ED}" -name '*.pyc' -exec rm -f {} \; || die
+ find "${ED}" -name '*.pyo' -exec rm -f {} \; || die
+ python_optimize
+}
+
+src_test() {
+ local myctestargs=(
+ -E "(check_lgpl)"
+ )
+ cmake_src_test
+}