summaryrefslogtreecommitdiff
path: root/sci-libs/volk/volk-2.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
commitec321939a77843497c860196ea06d7776d94b755 (patch)
tree426c3b59f57bfb684b461e65c4416048b369b4ce /sci-libs/volk/volk-2.4.1.ebuild
parent2982504d287f7f91eade76902f11e691f8181071 (diff)
gentoo auto-resync : 02:09:2022 - 22:17:13
Diffstat (limited to 'sci-libs/volk/volk-2.4.1.ebuild')
-rw-r--r--sci-libs/volk/volk-2.4.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/sci-libs/volk/volk-2.4.1.ebuild b/sci-libs/volk/volk-2.4.1.ebuild
deleted file mode 100644
index aff22b50715c..000000000000
--- a/sci-libs/volk/volk-2.4.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-#https://github.com/gnuradio/volk/issues/383
-CMAKE_BUILD_TYPE="None"
-inherit cmake python-single-r1
-
-DESCRIPTION="vector optimized library of kernels"
-HOMEPAGE="http://libvolk.org"
-SRC_URI="https://github.com/gnuradio/volk/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0/$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="orc test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
- !<net-wireless/gnuradio-3.8
- dev-libs/boost:=
- orc? ( dev-lang/orc )"
-DEPEND="${RDEPEND}
- $(python_gen_cond_dep 'dev-python/mako[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]')"
-
-RESTRICT="test"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_ORC=$(usex orc)
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DENABLE_TESTING="$(usex test)"
- -DENABLE_PROFILING=OFF
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- python_optimize
-}