summaryrefslogtreecommitdiff
path: root/sci-libs/tensorpipe/tensorpipe-2022.05.13-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-14 22:02:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-14 22:02:07 +0100
commit78db24b58a7f75bf18548cbf5c3b210f2f33f2f4 (patch)
tree53f180d30387a94fd028e0c5a10635621ebeb98f /sci-libs/tensorpipe/tensorpipe-2022.05.13-r1.ebuild
parent153fd195574cc30040446316bb666af0e58d985f (diff)
gentoo auto-resync : 14:05:2023 - 22:02:07
Diffstat (limited to 'sci-libs/tensorpipe/tensorpipe-2022.05.13-r1.ebuild')
-rw-r--r--sci-libs/tensorpipe/tensorpipe-2022.05.13-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/tensorpipe/tensorpipe-2022.05.13-r1.ebuild b/sci-libs/tensorpipe/tensorpipe-2022.05.13-r1.ebuild
new file mode 100644
index 000000000000..734a2050cf07
--- /dev/null
+++ b/sci-libs/tensorpipe/tensorpipe-2022.05.13-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+CommitId=bb1473a4b38b18268e8693044afdb8635bc8351b
+
+DESCRIPTION="provides a tensor-aware channel"
+HOMEPAGE="https://github.com/pytorch/tensorpipe/"
+SRC_URI="https://github.com/pytorch/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cuda"
+RESTRICT=test
+
+RDEPEND="
+ dev-libs/libuv
+ cuda? (
+ dev-util/nvidia-cuda-toolkit:=
+ )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libnop
+"
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DTP_USE_CUDA=$(usex cuda)
+ )
+ cmake_src_configure
+}