summaryrefslogtreecommitdiff
path: root/sci-libs/tensorflow-estimator/tensorflow-estimator-2.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-14 17:36:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-14 17:36:29 +0000
commit0485fd7e57de60b61c04825f986bb3400bcf7116 (patch)
tree8bc2ab515d65bccf3fa878f133e82577074ee982 /sci-libs/tensorflow-estimator/tensorflow-estimator-2.11.0.ebuild
parent3a5772102e4f2b6f9cc46f461c90970060ae0c5e (diff)
gentoo auto-resync : 14:02:2024 - 17:36:28
Diffstat (limited to 'sci-libs/tensorflow-estimator/tensorflow-estimator-2.11.0.ebuild')
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-2.11.0.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-2.11.0.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.11.0.ebuild
deleted file mode 100644
index 63ebc5a919ba..000000000000
--- a/sci-libs/tensorflow-estimator/tensorflow-estimator-2.11.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_10 )
-MY_PN="estimator"
-MY_PV=${PV}-rc0
-MY_P=${MY_PN}-${MY_PV}
-
-inherit bazel distutils-r1
-
-DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
-HOMEPAGE="https://www.tensorflow.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-bazel_external_uris="
- https://github.com/bazelbuild/rules_cc/archive/b1c40e1de81913a3c40e5948f78719c28152486d.zip -> bazelbuild-rules_cc-b1c40e1de81913a3c40e5948f78719c28152486d.zip
- https://github.com/bazelbuild/rules_java/archive/7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip -> bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip"
-
-SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}-rc0.tar.gz
- ${bazel_external_uris}"
-
-RDEPEND="
- sci-libs/tensorflow[python,${PYTHON_USEDEP}]
- sci-libs/keras[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/unzip
- >=dev-build/bazel-5.1.1
- dev-java/java-config
-"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CONTRIBUTING.md README.md )
-PATCHES=(
- # Tag is missing for v2.11.0, apply version update manually
- "${FILESDIR}/0001-Update-setup.py-for-2.11.0-final-release.patch"
-)
-
-src_unpack() {
- unpack "${P}-rc0.tar.gz"
- bazel_load_distfiles "${bazel_external_uris}"
-}
-
-src_prepare() {
- bazel_setup_bazelrc
- default
- python_copy_sources
-}
-
-python_compile() {
- pushd "${BUILD_DIR}" >/dev/null || die
-
- ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
- ebazel shutdown
-
- local srcdir="${T}/src-${EPYTHON/./_}"
- mkdir -p "${srcdir}" || die
- bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
-
- popd >/dev/null || die
-}
-
-src_compile() {
- export JAVA_HOME=$(java-config --jre-home)
- distutils-r1_src_compile
-}
-
-python_install() {
- pushd "${T}/src-${EPYTHON/./_}" >/dev/null || die
- esetup.py install
- python_optimize
- popd >/dev/null || die
-}