summaryrefslogtreecommitdiff
path: root/sci-libs/tamu_anova/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/tamu_anova/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/tamu_anova/files')
-rw-r--r--sci-libs/tamu_anova/files/0.2.1-gentoo.patch35
-rw-r--r--sci-libs/tamu_anova/files/tamu_anova-0.2.1-texinfo5.1.patch39
2 files changed, 74 insertions, 0 deletions
diff --git a/sci-libs/tamu_anova/files/0.2.1-gentoo.patch b/sci-libs/tamu_anova/files/0.2.1-gentoo.patch
new file mode 100644
index 000000000000..4d4c1f4a0af1
--- /dev/null
+++ b/sci-libs/tamu_anova/files/0.2.1-gentoo.patch
@@ -0,0 +1,35 @@
+diff --git a/Makefile.am b/Makefile.am
+index 6b11b79..ba5fac3 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,11 +1,11 @@
+-inst_LIBRARIES = libtamuanova.a
++lib_LTLIBRARIES = libtamuanova.la
+ pkginclude_HEADERS = tamu_anova.h
+-libtamuanova_a_SOURCES = anova_1.c anova_2.c
+-instdir = /usr/lib/
++libtamuanova_la_SOURCES = anova_1.c anova_2.c
++libtamuanova_la_LIBADD = $(GSL_LIBS)
+
+ TESTS = $(check_PROGRAMS)
+ check_PROGRAMS = test
+-test_LDADD = libtamuanova.a -lgsl -lgslcblas -lm
++test_LDADD = libtamuanova.la $(GSL_LIBS) -lm
+ test_SOURCES = test.c
+
+ CLEANFILES = test.dat
+diff --git a/configure.ac b/configure.ac
+index 7008594..1f161c3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -7,6 +7,10 @@ AM_INIT_AUTOMAKE([gnu no-dependencies])
+ AC_CONFIG_HEADER([config.h])
+
+ AC_PROG_MAKE_SET
++AC_PROG_LIBTOOL
++PKG_PROG_PKG_CONFIG
++
++PKG_CHECK_MODULES(GSL, [ gsl ])
+
+ dnl Check for which system.
+ AC_CANONICAL_HOST
diff --git a/sci-libs/tamu_anova/files/tamu_anova-0.2.1-texinfo5.1.patch b/sci-libs/tamu_anova/files/tamu_anova-0.2.1-texinfo5.1.patch
new file mode 100644
index 000000000000..f0c0570fc46d
--- /dev/null
+++ b/sci-libs/tamu_anova/files/tamu_anova-0.2.1-texinfo5.1.patch
@@ -0,0 +1,39 @@
+ fdl.texi | 2 +-
+ tamu_anova.texi | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/fdl.texi b/fdl.texi
+index 006dec7..6d8114a 100644
+--- a/fdl.texi
++++ b/fdl.texi
+@@ -403,7 +403,7 @@ number of this License, you may choose any version ever published (not
+ as a draft) by the Free Software Foundation.
+ @end enumerate
+
+-@unnumberedsubsec ADDENDUM: How to use this License for your documents
++@unnumberedsec ADDENDUM: How to use this License for your documents
+
+ To use this License in a document you have written, include a copy of
+ the License in the document and put the following copyright and
+diff --git a/tamu_anova.texi b/tamu_anova.texi
+index 8d4cd5b..5fba0e5 100644
+--- a/tamu_anova.texi
++++ b/tamu_anova.texi
+@@ -177,7 +177,7 @@ that the first effect is the fixed effect, while the second effect is the random
+ @section Structures
+ @b{One way table}
+
+-@deftypefn {struct tamu_anova_table}
++@deftypefn {Structures} struct tamu_anova_table
+ @code{struct tamu_anova_table@{
+ long df_tr, df_err, df_tot;
+ double SSTr, SSE, SST, MSTr, MSE, F, p;@};
+@@ -185,7 +185,7 @@ that the first effect is the fixed effect, while the second effect is the random
+ @end deftypefn
+ @*
+ @b{Two way table}
+-@deftypefn {struct tamu_anova_table_twoway}
++@deftypefn {Structures} struct tamu_anova_table_twoway
+ @code{struct tamu_anova_table_twoway @{
+ long
+ dfA, dfB, dfAB, dfT, dfE;