summaryrefslogtreecommitdiff
path: root/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sci-libs/ta-lib/ta-lib-0.4.0.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sci-libs/ta-lib/ta-lib-0.4.0.ebuild')
-rw-r--r--sci-libs/ta-lib/ta-lib-0.4.0.ebuild31
1 files changed, 21 insertions, 10 deletions
diff --git a/sci-libs/ta-lib/ta-lib-0.4.0.ebuild b/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
index 99cb7258bb33..7a7a581a503c 100644
--- a/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
+++ b/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils
+inherit autotools
DESCRIPTION="Technical Analysis Library for analyzing financial markets trends"
HOMEPAGE="http://www.ta-lib.org/"
@@ -14,15 +12,28 @@ SRC_URI="mirror://sourceforge/ta-lib/${P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
-S="${WORKDIR}"/${PN}
+S="${WORKDIR}/${PN}"
PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
-AUTOTOOLS_IN_SOURCE_BUILD=1
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
src_test() {
- ewarn "Note: this testsuite will fail without an active internet connection."
- "${S}"/src/tools/ta_regtest/ta_regtest || die "Failed testsuite."
+ src/tools/ta_regtest/ta_regtest || die
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}