summaryrefslogtreecommitdiff
path: root/sci-libs/szip/szip-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/szip/szip-2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/szip/szip-2.1.ebuild')
-rw-r--r--sci-libs/szip/szip-2.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-libs/szip/szip-2.1.ebuild b/sci-libs/szip/szip-2.1.ebuild
new file mode 100644
index 000000000000..d9bbe95a2464
--- /dev/null
+++ b/sci-libs/szip/szip-2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="Implementation of the extended-Rice lossless compression algorithm"
+HOMEPAGE="http://www.hdfgroup.org/doc_resource/SZIP/"
+SRC_URI="ftp://ftp.hdfgroup.org/lib-external/${PN}/${PV}/src/${P}.tar.gz"
+LICENSE="szip"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+
+IUSE=""
+DEPEND=""
+RDEPEND="!sci-libs/libaec"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc RELEASE.txt HISTORY.txt
+ insinto /usr/share/doc/${PF}/
+ emake -C examples clean || die
+ doins -r examples
+}