summaryrefslogtreecommitdiff
path: root/sci-libs/suitesparse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sci-libs/suitesparse
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sci-libs/suitesparse')
-rw-r--r--sci-libs/suitesparse/Manifest3
-rw-r--r--sci-libs/suitesparse/metadata.xml19
-rw-r--r--sci-libs/suitesparse/suitesparse-5.4.0.ebuild27
3 files changed, 44 insertions, 5 deletions
diff --git a/sci-libs/suitesparse/Manifest b/sci-libs/suitesparse/Manifest
index b3fee50ed1f5..2d28517af5e9 100644
--- a/sci-libs/suitesparse/Manifest
+++ b/sci-libs/suitesparse/Manifest
@@ -1,3 +1,4 @@
EBUILD suitesparse-4.0.2.ebuild 762 BLAKE2B b2eb7df499c9ac1f8e27f0bf90fa8178303090ea3819fc3945603b94d3c3a4259823f7f46f2d824d9d69ec6d457cd1c03a9781e98e4b04706147fd0adc6e2083 SHA512 57ac75b2b86bd6f5476144db5561c0d3197ecdfedccdd7673952c928f6d0c85858c348d8e2821384e802a107870157a0fd7aade95ca7d30aea374642af7af3a2
EBUILD suitesparse-4.2.1.ebuild 762 BLAKE2B 598b35b6165b24cc5e34f9df5ab3f695d79cee04f693c55d0d302ca5d7e2d52f193ba99fc459af97cfd2fd9badc293e6d814b578b17277a35255a0a16e94fb78 SHA512 7232069fb3d9f5ebc31424d1c88a930b27756a4a111993c8c607b7c5e1df59e089e5c5f578e331f77837c910ad81718166d7c922fe95a571722885c6ff1cc951
-MISC metadata.xml 1796 BLAKE2B d08361dcba469f44488448b20523593502049d5ec571874cdcce310801e1dca66695eb363e6eaba9031d7e0896c0e8f71f98d39f438cc7b40d046577a907491d SHA512 43f5cb3b418015616d24602efadd65cac6f1ea68a552c636d6cb032d00ab6d01c64371477c02d0cbc17dba81edace0148abe7b8babe9f56581abac5e13d4e17a
+EBUILD suitesparse-5.4.0.ebuild 754 BLAKE2B 0ecc95375e4a6bbc5a4d5732802eddb292fe6e5e261da842a18578a4d6d7016ce3c9164a3ef7ce8c15d176980027af6423b2e14c981e308f1f0ee7ddd2827a32 SHA512 469d1d6f80d27382eb9c44bbe98873859ce0556b729a462a0e9abd2403066d3d9199cc84dd7f63211f1bdf102a3034cb60a737890cfe1ceb3f43b0a7ebea036c
+MISC metadata.xml 1995 BLAKE2B 34721d419d77f93f3dac7d99cde6d41f8ea9ed7bdb87a8b88b02da1a151b9dce4b415da56176ba07ef83f55692b9520aea2dd2eaa0b90f5e6847585908e8c4be SHA512 855650d41560fa1a9ad9dd6d7136328f744eb07ea086a275485edb147da394787a92c56890bd8a8613ef2dbf94a32d9c94698c54916461150c5013504817aa03
diff --git a/sci-libs/suitesparse/metadata.xml b/sci-libs/suitesparse/metadata.xml
index a30fdd382ec1..d8c0d9a2971e 100644
--- a/sci-libs/suitesparse/metadata.xml
+++ b/sci-libs/suitesparse/metadata.xml
@@ -26,11 +26,22 @@
* RBio: MATLAB toolbox for reading/writing sparse matrices
* LINFACTOR: solve Ax=b using LU or CHOL
* MESHND: 2D and 3D mesh generation and nested dissection
- * SSMULT: sparse matrix times sparse matrix
+ * SSMULT: sparse matrix times sparse matrix
</longdescription>
<use>
- <flag name="cuda">Enable nvidia cuda toolkit for speeding up computations</flag>
- <flag name="metis">Enable the Partition module to cholmod using <pkg>sci-libs/metis</pkg></flag>
- <flag name="tbb">Enable multithreading with the Intel Threads Building Block <pkg>dev-cpp/tbb</pkg></flag>
+ <flag name="cuda">
+ Enable nvidia cuda toolkit for speeding up computations
+ </flag>
+ <flag name="metis">
+ Enable the Partition module to cholmod using <pkg>sci-libs/metis</pkg>
+ </flag>
+ <flag name="partition">
+ Enable graph partitioning and graph-partition-based orderings
+ through <pkg>sci-libs/metis</pkg> or <pkg>sci-libs/parmetis</pkg>
+ </flag>
+ <flag name="tbb">
+ Enable multithreading with the Intel Threads Building Block
+ <pkg>dev-cpp/tbb</pkg>
+ </flag>
</use>
</pkgmetadata>
diff --git a/sci-libs/suitesparse/suitesparse-5.4.0.ebuild b/sci-libs/suitesparse/suitesparse-5.4.0.ebuild
new file mode 100644
index 000000000000..2098b0804964
--- /dev/null
+++ b/sci-libs/suitesparse/suitesparse-5.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Metapackage for a suite of sparse matrix tools"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+
+LICENSE="metapackage"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda doc lapack partition tbb"
+DEPEND=""
+RDEPEND="
+ ~sci-libs/suitesparseconfig-${PV}
+ ~sci-libs/amd-2.4.6[doc?]
+ ~sci-libs/btf-1.2.6
+ ~sci-libs/camd-2.4.6[doc?]
+ ~sci-libs/ccolamd-2.9.6
+ ~sci-libs/cholmod-3.0.13[cuda?,doc?,partition?,lapack?]
+ ~sci-libs/colamd-2.9.6
+ ~sci-libs/cxsparse-3.2.0
+ ~sci-libs/klu-1.3.9[doc?]
+ ~sci-libs/ldl-2.2.6[doc?]
+ ~sci-libs/spqr-2.0.9[doc?,partition?,tbb?]
+ ~sci-libs/umfpack-5.7.9[doc?,cholmod]"