summaryrefslogtreecommitdiff
path: root/sci-libs/spqr/spqr-2.0.9-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sci-libs/spqr/spqr-2.0.9-r2.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sci-libs/spqr/spqr-2.0.9-r2.ebuild')
-rw-r--r--sci-libs/spqr/spqr-2.0.9-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/spqr/spqr-2.0.9-r2.ebuild b/sci-libs/spqr/spqr-2.0.9-r2.ebuild
new file mode 100644
index 000000000000..ff1a265ca5a0
--- /dev/null
+++ b/sci-libs/spqr/spqr-2.0.9-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="doc partition tbb"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+# We require the cholmod supernodal module that is enabled with
+# USE=lapack, and cholmod has to have partition support if spqr is going
+# to have it (the ./configure script for spqr checks this). Note that
+# spqr links to metis directly, too.
+DEPEND="
+ virtual/lapack
+ >=sci-libs/cholmod-2[lapack,partition?]
+ partition? ( >=sci-libs/metis-5.1.0 )
+ tbb? ( <dev-cpp/tbb-2021:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with doc) \
+ $(use_with partition) \
+ $(use_with tbb)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}