summaryrefslogtreecommitdiff
path: root/sci-libs/silo/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/silo/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/silo/files')
-rw-r--r--sci-libs/silo/files/silo-4.10.2-mpiposix.patch53
-rw-r--r--sci-libs/silo/files/silo-4.10.2-qtlibs.patch66
-rw-r--r--sci-libs/silo/files/silo-4.10.2-tests.patch11
-rw-r--r--sci-libs/silo/files/silo-4.9.1-qtlibs.patch66
-rw-r--r--sci-libs/silo/files/silo-4.9.1-tests.patch11
5 files changed, 207 insertions, 0 deletions
diff --git a/sci-libs/silo/files/silo-4.10.2-mpiposix.patch b/sci-libs/silo/files/silo-4.10.2-mpiposix.patch
new file mode 100644
index 000000000000..30a3f910b196
--- /dev/null
+++ b/sci-libs/silo/files/silo-4.10.2-mpiposix.patch
@@ -0,0 +1,53 @@
+--- src/hdf5_drv/silo_hdf5.c.orig 2017-07-28 08:52:09.026638768 +0200
++++ src/hdf5_drv/silo_hdf5.c 2017-07-28 09:00:12.306635882 +0200
+@@ -4752,18 +4752,19 @@
+ }
+
+ /* default HDF5 mpi drivers */
+- case DB_FILE_OPTS_H5_DEFAULT_MPIP:
+- {
+-#ifdef H5_HAVE_PARALLEL
+- h5status |= H5Pset_fapl_mpiposix(retval, MPI_COMM_SELF, TRUE);
+-#else
+- H5Pclose(retval);
+- return db_perror("HDF5 MPI VFD", E_NOTENABLEDINBUILD, me);
+-#endif
+- break;
+- }
++// case DB_FILE_OPTS_H5_DEFAULT_MPIP:
++// {
++//#ifdef H5_HAVE_PARALLEL
++// h5status |= H5Pset_fapl_mpiposix(retval, MPI_COMM_SELF, TRUE);
++//#else
++// H5Pclose(retval);
++// return db_perror("HDF5 MPI VFD", E_NOTENABLEDINBUILD, me);
++//#endif
++// break;
++// }
+
+ case DB_FILE_OPTS_H5_DEFAULT_MPIO:
++ case DB_FILE_OPTS_H5_DEFAULT_MPIP:
+ {
+ #ifdef H5_HAVE_PARALLEL
+ MPI_Info info;
+@@ -5069,15 +5070,15 @@
+ if ((p = DBGetOption(opts, DBOPT_H5_MPIP_NO_GPFS_HINTS)))
+ use_gpfs_hints = FALSE;
+
+- if (vfd == DB_H5VFD_MPIO)
++// if (vfd == DB_H5VFD_MPIO)
+ {
+ h5status |= H5Pset_fapl_mpio(retval, mpi_comm, mpi_info);
+ if (created_info) MPI_Info_free(&mpi_info);
+ }
+- else
+- {
+- h5status |= H5Pset_fapl_mpiposix(retval, mpi_comm, use_gpfs_hints);
+- }
++// else
++// {
++// h5status |= H5Pset_fapl_mpiposix(retval, mpi_comm, use_gpfs_hints);
++// }
+ #else
+ H5Pclose(retval);
+ return db_perror("HDF5 MPI VFD", E_NOTENABLEDINBUILD, me);
diff --git a/sci-libs/silo/files/silo-4.10.2-qtlibs.patch b/sci-libs/silo/files/silo-4.10.2-qtlibs.patch
new file mode 100644
index 000000000000..e8fc4284cac0
--- /dev/null
+++ b/sci-libs/silo/files/silo-4.10.2-qtlibs.patch
@@ -0,0 +1,66 @@
+diff -ru silo-4.9.1-old/configure silo-4.9.1-new/configure
+--- silo-4.9.1-old/configure 2014-01-18 23:19:15.755030306 +0100
++++ silo-4.9.1-new/configure 2014-01-18 23:20:52.595031159 +0100
+@@ -27503,7 +27503,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # Use cached value or do search, starting with suggestions from
+ # the command line
+@@ -27577,7 +27577,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # There is no valid definition for $QTDIR as Trolltech likes to see it
+ ax_qt_dir=
+@@ -27589,7 +27589,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # Normally, when there is no traditional Trolltech installation,
+ # the library is installed in a place where the linker finds it
+@@ -27607,7 +27607,7 @@
+ # See if we find the library without any special options.
+ # Don't add top $LIBS permanently yet
+ ax_save_LIBS="$LIBS"
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ ax_qt_LIBS="$LIBS"
+ ax_save_CXXFLAGS="$CXXFLAGS"
+ CXXFLAGS="-I$ax_qt_include_dir -I$ax_qt_include_dir/Qt -I$ax_qt_include_dir/QtCore -I$ax_qt_include_dir/QtGui"
+@@ -27668,7 +27668,7 @@
+ # That did not work. Try the multi-threaded version
+ echo "Non-critical error, please neglect the above." >&5
+ ax_qt_lib=qt-mt
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -27726,7 +27726,7 @@
+ # That did not work. Try the OpenGL version
+ echo "Non-critical error, please neglect the above." >&5
+ ax_qt_lib=qt-gl
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -27809,7 +27809,7 @@
+ fi
+ done
+ # Try with that one
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
diff --git a/sci-libs/silo/files/silo-4.10.2-tests.patch b/sci-libs/silo/files/silo-4.10.2-tests.patch
new file mode 100644
index 000000000000..2e0a52191d0e
--- /dev/null
+++ b/sci-libs/silo/files/silo-4.10.2-tests.patch
@@ -0,0 +1,11 @@
+--- tests/Makefile.in.old 2014-07-24 07:25:53.464381420 +0200
++++ tests/Makefile.in 2014-07-24 07:26:14.951048323 +0200
+@@ -169,7 +169,7 @@
+ $(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+ $(ioperf_stdio_la_LDFLAGS) $(LDFLAGS) -o $@
+ rocket_silo_la_LIBADD =
+-am_rocket_silo_la_OBJECTS = rocket_silo.lo
++am_rocket_silo_la_OBJECTS = rocket_silo.lo ../src/.libs/libsilo.la
+ rocket_silo_la_OBJECTS = $(am_rocket_silo_la_OBJECTS)
+ rocket_silo_la_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=link $(CXXLD) $(AM_CXXFLAGS) \
diff --git a/sci-libs/silo/files/silo-4.9.1-qtlibs.patch b/sci-libs/silo/files/silo-4.9.1-qtlibs.patch
new file mode 100644
index 000000000000..e8fc4284cac0
--- /dev/null
+++ b/sci-libs/silo/files/silo-4.9.1-qtlibs.patch
@@ -0,0 +1,66 @@
+diff -ru silo-4.9.1-old/configure silo-4.9.1-new/configure
+--- silo-4.9.1-old/configure 2014-01-18 23:19:15.755030306 +0100
++++ silo-4.9.1-new/configure 2014-01-18 23:20:52.595031159 +0100
+@@ -27503,7 +27503,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # Use cached value or do search, starting with suggestions from
+ # the command line
+@@ -27577,7 +27577,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # There is no valid definition for $QTDIR as Trolltech likes to see it
+ ax_qt_dir=
+@@ -27589,7 +27589,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # Normally, when there is no traditional Trolltech installation,
+ # the library is installed in a place where the linker finds it
+@@ -27607,7 +27607,7 @@
+ # See if we find the library without any special options.
+ # Don't add top $LIBS permanently yet
+ ax_save_LIBS="$LIBS"
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ ax_qt_LIBS="$LIBS"
+ ax_save_CXXFLAGS="$CXXFLAGS"
+ CXXFLAGS="-I$ax_qt_include_dir -I$ax_qt_include_dir/Qt -I$ax_qt_include_dir/QtCore -I$ax_qt_include_dir/QtGui"
+@@ -27668,7 +27668,7 @@
+ # That did not work. Try the multi-threaded version
+ echo "Non-critical error, please neglect the above." >&5
+ ax_qt_lib=qt-mt
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -27726,7 +27726,7 @@
+ # That did not work. Try the OpenGL version
+ echo "Non-critical error, please neglect the above." >&5
+ ax_qt_lib=qt-gl
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -27809,7 +27809,7 @@
+ fi
+ done
+ # Try with that one
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
diff --git a/sci-libs/silo/files/silo-4.9.1-tests.patch b/sci-libs/silo/files/silo-4.9.1-tests.patch
new file mode 100644
index 000000000000..2e0a52191d0e
--- /dev/null
+++ b/sci-libs/silo/files/silo-4.9.1-tests.patch
@@ -0,0 +1,11 @@
+--- tests/Makefile.in.old 2014-07-24 07:25:53.464381420 +0200
++++ tests/Makefile.in 2014-07-24 07:26:14.951048323 +0200
+@@ -169,7 +169,7 @@
+ $(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+ $(ioperf_stdio_la_LDFLAGS) $(LDFLAGS) -o $@
+ rocket_silo_la_LIBADD =
+-am_rocket_silo_la_OBJECTS = rocket_silo.lo
++am_rocket_silo_la_OBJECTS = rocket_silo.lo ../src/.libs/libsilo.la
+ rocket_silo_la_OBJECTS = $(am_rocket_silo_la_OBJECTS)
+ rocket_silo_la_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=link $(CXXLD) $(AM_CXXFLAGS) \