summaryrefslogtreecommitdiff
path: root/sci-libs/scalapack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/scalapack
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/scalapack')
-rw-r--r--sci-libs/scalapack/Manifest5
-rw-r--r--sci-libs/scalapack/metadata.xml15
-rw-r--r--sci-libs/scalapack/scalapack-2.0.2.ebuild63
3 files changed, 83 insertions, 0 deletions
diff --git a/sci-libs/scalapack/Manifest b/sci-libs/scalapack/Manifest
new file mode 100644
index 000000000000..3bf3213f9b50
--- /dev/null
+++ b/sci-libs/scalapack/Manifest
@@ -0,0 +1,5 @@
+DIST scalapack-2.0.2.tgz 4779534 SHA256 0c74aeae690fe5ee4db7926f49c5d0bb69ce09eea75beb915e00bba07530395c SHA512 92c71d3de0900955511c527ab3ca57ff69d6d9edc390e69f93ac3769d32ce83a714326bcb6218c8c74b8874be2fdc8aad5e42c912a12581e8d4ce8829ea39248 WHIRLPOOL ca5e9261bb046684ecb820247ae2d9953083f9989b5cdeccd033c67519a5ab1eb3bd3f12d0225767513d5307342ccd96f582dbd264b2decc9033bf1f7f5d7dbc
+EBUILD scalapack-2.0.2.ebuild 1514 SHA256 f7e6d27f58f1ef6e24a310dc53beaba1c34ff0949f438f7e41d69597053d8c2d SHA512 9eaf38dcb6e4ddd29b0c4c7b102f0eba96985e2e3b2dbe44790d6c3c39d8d8b8f9afec439de237418ba78dc11c44745b7e046738140a3fa6fe314322350e87ad WHIRLPOOL 85bf9fca09012e6ba52d4dc6b8e914438a4088b6436a70ec4c1cbe8842c9ae929108d5b94649a0de157e104923d2b05ad7183be0e366860b95659504314a3651
+MISC ChangeLog 2433 SHA256 d7b790787fe94b35830012af1fef71e05fb206aef092abb8f84f21a31bdbabbd SHA512 6a6ca0518d5be3291b4fa31777301b9d46428d292dfb12ae55ec2da211c2884cb61c1c27b6b4acaa3e433fdb61df09dfceeb5251e140f5ca8862aedae82575dc WHIRLPOOL b72b6d21869240574e3ce623c5c53399db940a87e55ded5bced999a08e7286b2324026bae81d4fcaf65ad09bf39db73d9f7816a673e2ad23f25bcd267e3176e4
+MISC ChangeLog-2015 1687 SHA256 f5ae5b5a27d6e63f8d829112518e0b643b0362e163a7a945acfbe1f69f3bc4d2 SHA512 11e58a7c94e35f2e3759d895d518a6f610a81beeac86153893710a3328fa2bab41efdaaf8e3e7bdba0452510dd53f9c8f3153358726649b9d27e7cf28a1f09ae WHIRLPOOL c9537f569698c1f9a89f131f1d76b0b6be7653abfa09db86665092cb43b485a1a51f70ff56a2a97323f157141d115f4148b935e4ce55ecfcf30735b9d34df18a
+MISC metadata.xml 656 SHA256 3299fbdac46be798a2e2373f1a29f05ecf046e16bce1d19e10c247b13894da87 SHA512 c0ee34b1315583fd3d46f707c56ca1c5d3ff5bc85c2a96c65ca02258d3e6799ed6d9f3e3352d8bacd3053681e7b1b15e55049a62520c933df06ede6022786354 WHIRLPOOL a88416e87d2123853427721d8181ede3f79c96fa16c43e46601d676a9544903e3c57a922849663924d4fb113466f83eded75b81cac77cb5e5a01b797626858ea
diff --git a/sci-libs/scalapack/metadata.xml b/sci-libs/scalapack/metadata.xml
new file mode 100644
index 000000000000..b538e0aef078
--- /dev/null
+++ b/sci-libs/scalapack/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription lang="en">
+ The ScaLAPACK (or Scalable LAPACK) library includes a subset of LAPACK routines
+ redesigned for distributed memory MIMD parallel computers. It is currently
+ written in a Single-Program-Multiple-Data style using explicit message
+ passing for interprocessor communication. It assumes matrices are laid out
+ in a two-dimensional block cyclic decomposition.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/scalapack/scalapack-2.0.2.ebuild b/sci-libs/scalapack/scalapack-2.0.2.ebuild
new file mode 100644
index 000000000000..fadcb6568bd5
--- /dev/null
+++ b/sci-libs/scalapack/scalapack-2.0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils eutils fortran-2
+
+DESCRIPTION="Subset of LAPACK routines redesigned for heterogenous (MPI) computing"
+HOMEPAGE="http://www.netlib.org/scalapack/"
+SRC_URI="${HOMEPAGE}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+
+RDEPEND="
+ virtual/lapack
+ virtual/mpi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ use static-libs && mkdir "${WORKDIR}/${PN}_static"
+ # mpi does not have a pc file
+ sed -i -e 's/mpi//' scalapack.pc.in || die
+}
+
+src_configure() {
+ scalapack_configure() {
+ local mycmakeargs=(
+ -DUSE_OPTIMIZED_LAPACK_BLAS=ON
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
+ -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
+ $(cmake-utils_use_build test TESTING)
+ $@
+ )
+ cmake-utils_src_configure
+ }
+
+ scalapack_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
+ use static-libs && \
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" scalapack_configure \
+ -DBUILD_SHARED_LIBS=OFF -DBUILD_STATIC_LIBS=ON
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use static-libs && \
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ use static-libs && \
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install
+
+ insinto /usr/include/blacs
+ doins BLACS/SRC/*.h
+
+ insinto /usr/include/scalapack
+ doins PBLAS/SRC/*.h
+}