summaryrefslogtreecommitdiff
path: root/sci-libs/rtree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sci-libs/rtree
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sci-libs/rtree')
-rw-r--r--sci-libs/rtree/Manifest3
-rw-r--r--sci-libs/rtree/metadata.xml17
-rw-r--r--sci-libs/rtree/rtree-0.9.4-r1.ebuild32
3 files changed, 52 insertions, 0 deletions
diff --git a/sci-libs/rtree/Manifest b/sci-libs/rtree/Manifest
new file mode 100644
index 000000000000..e5468bb11ca9
--- /dev/null
+++ b/sci-libs/rtree/Manifest
@@ -0,0 +1,3 @@
+DIST Rtree-0.9.4.tar.gz 62017 BLAKE2B 72a979a3b9b9e9e1d18ea8646bbf860413c18420ce40946108c4f2f0e59fcb5bb64971a57936a92714e02e13419f7dc594b2371e4b44a4fd6a3e3986c19f7d85 SHA512 59981ffefedac1162faaa86ea10d7d5503da46c7ae9588a57e1a49214043de5f41bd4836965651d4cd22e7959c37cc6d586d9912568a2aaf693a0afb7895b429
+EBUILD rtree-0.9.4-r1.ebuild 633 BLAKE2B 6b0a78df3e79e41a23174ba873f306fcc43f7ceddc93dafd66ac27d8dc2541b374b5f0d5a83715f263d4cad375d2a82f07b6bba147a372ebd92f5f05b1efac12 SHA512 c2bb26c76f00e08e8745c02096916ca66321fb8e351d009382ac35c8abb434605e146db33ec324e5406b0c88408c962b0bea0281c5e775587a16fb0c490b9274
+MISC metadata.xml 701 BLAKE2B 1f89c6481c0856f2bd0ca2431151ecef5c01b015c443efcfb837be7cbe84ac218b3811e3710e678650916094ab9c8e0d18b2bb0a8beea10a7b6c73e7df23d646 SHA512 c145907e76558f657c5ca11540fc83ed3fe42917b496c4885b9826fdeb6253594f8656f9e663bbb519b47f3590ef0068f28e75f2a14248f7cc9508d7f8d7db81
diff --git a/sci-libs/rtree/metadata.xml b/sci-libs/rtree/metadata.xml
new file mode 100644
index 000000000000..d03728e20d7e
--- /dev/null
+++ b/sci-libs/rtree/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ Rtree is a ctypes Python wrapper of libspatialindex that provides a number of advanced spatial indexing
+ features for the spatially curious Python user.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/Toblerity/rtree/issues</bugs-to>
+ <remote-id type="github">Toblerity/rtree</remote-id>
+ <remote-id type="pypi">Rtree</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/rtree/rtree-0.9.4-r1.ebuild b/sci-libs/rtree/rtree-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..a0940fd1901a
--- /dev/null
+++ b/sci-libs/rtree/rtree-0.9.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_PN="Rtree"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="R-Tree spatial index for Python GIS"
+HOMEPAGE="https://rtree.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND="sci-libs/libspatialindex"
+
+distutils_enable_sphinx docs/source
+
+distutils_enable_tests pytest
+
+DEPEND+="
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )
+"