summaryrefslogtreecommitdiff
path: root/sci-libs/rocThrust
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /sci-libs/rocThrust
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'sci-libs/rocThrust')
-rw-r--r--sci-libs/rocThrust/Manifest1
-rw-r--r--sci-libs/rocThrust/rocThrust-4.3.0-r1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-libs/rocThrust/Manifest b/sci-libs/rocThrust/Manifest
index 04f35fcdfd10..135c25d12f73 100644
--- a/sci-libs/rocThrust/Manifest
+++ b/sci-libs/rocThrust/Manifest
@@ -3,5 +3,6 @@ AUX rocThrust-4.3.0-deprecate-hcc_detail.patch 492 BLAKE2B cde3fb2210e482f6b76e2
DIST rocThrust-4.0.0.tar.gz 1166346 BLAKE2B 02c89e0c4ab2c888a20b7c956a73012157f2735e6ec76369a1f75fbc17bb3f995d1914106ec58562f28243fbe5f019ac230ac3313b6aacb4d8b868f3ac1f091e SHA512 476aa5706487c5801cc91908806a1a1fcb550171f63e0b2debd9b59b18c7435c484578ec456ccfabc140dd7bca7d9bb432a7ba223946b1fca22e72e7d053af2d
DIST rocThrust-4.3.0.tar.gz 1156832 BLAKE2B a462cfaa31883253fabba584ca77622cc5a7234bd9979472a84ec77b91c60f48f1064149b86d624aaedd70262fb65fb6aadb03cc6e00939d4eed6cd11bfc0090 SHA512 8c6aa3aefd59c87cc8278930bf90021867f519c356c86a3c3ebfcdf90887b8631250b6a9a8156f77c0cbf7ddbad7881e5e1b802f1cd1305cc3a2e7d95ef4e6f3
EBUILD rocThrust-4.0.0-r1.ebuild 1244 BLAKE2B 4f8019ccf296a915a305a405d3e80d2de348ac7717782671b76306882872a6e356bdbdb63316094ce8ccc8410fced42db56423b4d96f8d690ec6838d3721612e SHA512 40671932493ab5a2a2597a4181d03c666a9272ed881d053ecc8d8285aa8a5b68b9527b4fa0e29b6acff3f31fdfafd9cc060b9e098b16a12a7370eaa37542f5de
+EBUILD rocThrust-4.3.0-r1.ebuild 2062 BLAKE2B 15a1efc0555989c16108f62d6c6c689fac172101565e771f32c36c5765a10105a7fd78cb90098e3746928b35271e3652b1a6880f451f087dc731950e237de40d SHA512 476c3cedfb959ff5764aa2893810ed9a09db58c172cc36ae91f215a35efb13354f3a363be6bd2ac1d5987739028930ce9d4ba73e36699973b7c413215462f713
EBUILD rocThrust-4.3.0.ebuild 2082 BLAKE2B 414354d8137a09e987b908bc901d404c0025cdd77df7753a602a04b14391637f9c04cb831f0819f61b53b01e12ad01e883547fb7135034dee57a4cd22980b444 SHA512 77fbb475bceb103df10f6dfe50fc74631337fb6e72473edb7a3db03f98ce5f1f66458a501cde22f6c79232107b810a0496323166fd11814e4ee4b694f8206a4d
MISC metadata.xml 656 BLAKE2B cdcee7af9e0c2f8e0553cc0d41ea208dbaa27aae0847f90b048e4c8791a9be511a84c7fb5ba8dc4c0409266d5a8a855fd4ebf578ad55c5882a000fbb4c5b05c0 SHA512 adefa0bbe1487a7c29a3b175c8d27e694c5464b0f7a3f20afcfd07952ef95cb54a789f7ae174053493d893338f52cf175f4b1939b998e850b62a7fd435dc592a
diff --git a/sci-libs/rocThrust/rocThrust-4.3.0-r1.ebuild b/sci-libs/rocThrust/rocThrust-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..fc6045bf31f2
--- /dev/null
+++ b/sci-libs/rocThrust/rocThrust-4.3.0-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="HIP back-end for the parallel algorithm library Thrust"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocThrust"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-${PV}.tar.gz -> rocThrust-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="benchmark test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/hip:${SLOT}
+ sci-libs/rocPRIM:${SLOT}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/rocThrust-rocm-${PV}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.0-operator_new.patch"
+ "${FILESDIR}/${P}-deprecate-hcc_detail.patch" )
+
+src_prepare() {
+ sed -e "/PREFIX rocthrust/d" \
+ -e "/DESTINATION/s:rocthrust/include/thrust:include/thrust:" \
+ -e "/rocm_install_symlink_subdir(rocthrust)/d" \
+ -e "/<INSTALL_INTERFACE/s:rocthrust/include/:include/:" -i thrust/CMakeLists.txt || die
+
+ sed -e "s:\${CMAKE_INSTALL_INCLUDEDIR}:&/rocthrust:" \
+ -e "s:\${ROCM_INSTALL_LIBDIR}:\${CMAKE_INSTALL_LIBDIR}:" -i cmake/ROCMExportTargetsHeaderOnly.cmake || die
+
+ # disable downloading googletest and googlebenchmark
+ sed -r -e '/Downloading/{:a;N;/\n *\)$/!ba; d}' -i cmake/Dependencies.cmake || die
+
+ # remove GIT dependency
+ sed -r -e '/find_package\(Git/{:a;N;/\nendif/!ba; d}' -i cmake/Dependencies.cmake || die
+
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Grant access to the device
+ addwrite /dev/kfd
+ addpredict /dev/dri/
+
+ # Compiler to use
+ export CXX=hipcc
+
+ local mycmakeargs=(
+ -DBUILD_TEST=$(usex test ON OFF)
+ -DBUILD_BENCHMARKS=$(usex benchmark ON OFF)
+ ${AMDGPU_TARGETS+-DAMDGPU_TARGETS="${AMDGPU_TARGETS}"}
+ -D__skip_rocmclang="ON" ## fix cmake-3.21 configuration issue caused by officialy support programming language "HIP"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Grant access to the device
+ addwrite /dev/kfd
+ addwrite /dev/dri/
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ use benchmark && dobin "${BUILD_DIR}"/benchmarks/benchmark_thrust_bench
+}