summaryrefslogtreecommitdiff
path: root/sci-libs/rocSPARSE/rocSPARSE-4.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-19 19:49:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-19 19:49:08 +0000
commitf287ecad888abdeb38e617d0485de282cd6819db (patch)
tree874d56500040734c4dbb9e437e0d5ed80a0a1886 /sci-libs/rocSPARSE/rocSPARSE-4.0.0-r1.ebuild
parent844ae757702c53a56ee57056873a8204d256d47e (diff)
gentoo auto-resync : 19:12:2022 - 19:49:08
Diffstat (limited to 'sci-libs/rocSPARSE/rocSPARSE-4.0.0-r1.ebuild')
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-4.0.0-r1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sci-libs/rocSPARSE/rocSPARSE-4.0.0-r1.ebuild b/sci-libs/rocSPARSE/rocSPARSE-4.0.0-r1.ebuild
deleted file mode 100644
index 14e2518eb4a7..000000000000
--- a/sci-libs/rocSPARSE/rocSPARSE-4.0.0-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Basic Linear Algebra Subroutines for sparse computation"
-HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocSPARSE"
-SRC_URI="https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-${PV}.tar.gz -> rocSPARSE-${PV}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="0"
-
-RDEPEND="=dev-util/hip-$(ver_cut 1-2)*
- =sci-libs/rocPRIM-$(ver_cut 1-2)*"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/rocSPARSE-rocm-${PV}"
-
-rocSPARSE_V="0.1"
-
-BUILD_DIR="${S}/build/release"
-
-src_prepare() {
- sed -e "s/PREFIX rocsparse//" \
- -e "/<INSTALL_INTERFACE/s,include,include/rocsparse," \
- -e "/rocm_install_symlink_subdir(rocsparse)/d" \
- -e "s:rocsparse/include:include/rocsparse:" \
- -i "${S}/library/CMakeLists.txt" || die
-
- eapply_user
- cmake_src_prepare
-}
-
-src_configure() {
- # Grant access to the device to omit a sandbox violation
- addwrite /dev/kfd
- addpredict /dev/dri/
-
- # Compiler to use
- export CXX=hipcc
-
- local mycmakeargs=(
- -DBUILD_CLIENTS_SAMPLES=OFF
- -DCMAKE_INSTALL_INCLUDEDIR="include/rocsparse"
- )
-
- cmake_src_configure
-}